×

Discussion Board

Results 1 to 5 of 5
  1. #1
    Registered User
    Join Date
    Dec 2008
    Posts
    2

    Unhappy TRK app installation fails

    i am trying to install s60_5_0_app_trk_3_2_6.sisx file on my N97 mini for on device debugging and testing of an app. BUt it is installing half way and just stops. Gives error Unable to install.
    When i try to install it from PC suite it gives Error code 2148532241.

    When i click on the Device Debug simulator it just give me message that " Try to Run TRK app from COM4"
    I guess my N97 mini gets connected via USB. BUt then even thought TRK is not installed on my mobile.

    what exactly wrong.

  2. #2
    Registered User
    Join Date
    Apr 2010
    Location
    Almaty, Kazakhstan
    Posts
    18

    Re: TRK app installation fails

    I had the same problem installing TRK from Nokia Qt SDK beta on my E55. In my case the device just rebooted. Then I have installed TRK from Carbide.C++ suite and it works just fine. Maybe this helps you too.

  3. #3
    Registered User
    Join Date
    Jul 2010
    Location
    Vienna
    Posts
    22

    Re: TRK app installation fails

    Hello!

    I need to write a few small applications for Nokia E51. So I downloaded and installed the QT IDE+SDK following the instructions from the QT Quick-Start guide. Everything worked just fine. After a few hours I did a firmware update on the E51. Reinstalling the QT Libraries on the phone was absolutely no problem, but I'm unable to install TRK - my phone's telling me, that it is already included in the system. But I couldn't find it on the phone. Google told me, that there is no TRK installer available for newer versions of the firmware.

    Now I have the problem, that I can't debug the applications on the phone, because QT IDE wants an TRK which I wasn't able to install.

    Could somebody tell me if it is on the system (included ) and if so, where I can start it? If not: How should we be able to debug apps on the phone?

    Thanks for your help.

  4. #4
    Super Contributor
    Join Date
    Dec 2005
    Location
    England,UK
    Posts
    1,600

    Re: TRK app installation fails

    Hi,
    When you say you attempted to install TRK and you got an error already installed
    I assume you tried to install
    Code:
    C:\NokiaQtSDK\Symbian\sis>dir s60_3_1_app_trk_3_1_2.sisx
     Volume in drive C has no label.
    
    
     Directory of C:\NokiaQtSDK\Symbian\sis
    
    16/07/2010  04:36            57,096 s60_3_1_app_trk_3_1_2.sisx
                   1 File(s)         57,096 bytes
                   0 Dir(s)  60,422,193,152 bytes free
    
    C:\NokiaQtSDK\Symbian\sis>
    The device specfication for E51 under Technical specification shows a 3rd Ed FP1 phone
    http://www.forum.nokia.com/Devices/D...fications/E51/

    Send the file above via pcsuite download link app installer. You just need to set the port to USB on App TRK app and
    This should work.
    Thanks,
    Jim
    Last edited by jimgilmour1; 2010-07-23 at 13:16. Reason: pc suite link

  5. #5
    Registered User
    Join Date
    Jul 2010
    Location
    Vienna
    Posts
    22

    Re: TRK app installation fails

    This is exactly what I try to do. I use the right version of TRK, but the E51 doesn't let me install it.
    Bevore I did a Symbian update the installation worked flawless. But since I did the update to the newest firmware - installing TRK is impossible.

    I've read - not sure if that's true - that Nokia wants to prevent the devices from getting hacked. But then I have to aks, what we developers should do, without a on-device debugger?
    There's no other place than 127.0.0.1

Similar Threads

  1. frustrating installation of s60 5th edition TRK app
    By skyozone in forum Symbian Tools & SDKs
    Replies: 2
    Last Post: 2010-09-08, 19:58
  2. App TRK :Not connected
    By waterInSky in forum Symbian
    Replies: 9
    Last Post: 2009-04-15, 11:20
  3. Replies: 5
    Last Post: 2008-10-26, 13:34
  4. App Trk
    By rami75lu in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 6
    Last Post: 2008-09-20, 13:45
  5. TRK Agent Installation
    By adamis22 in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 2
    Last Post: 2007-01-23, 16:48

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •