×

Discussion Board

Results 1 to 11 of 11
  1. #1
    Registered User
    Join Date
    Mar 2003
    Location
    Sweden, Stockholm
    Posts
    90

    Question Error message when install Nokia Qt SDK on Mac OS X

    Hi,
    I get this error:
    Error during installation process:
    Execution failed (Unexpected exit code: 2): "/Users/ove/NokiaQtSDK/Maemo/4.6.2/postinstall/postinstall.sh "

    the only way do go on with the installation is to press <Ignore>
    Then I get this error:
    Error during installation process:
    Error while extracting installer://com.nokia.ndk.api.qtmobility.simulatorgcc/QtMobility.7z: Extraction failed..

    the only way do go on with the installation is to press <Ignore>
    Then I get this error:
    Error during installation process:
    Can't invoke otool.

    What to do?
    I have also file a bug about this

    Regards,
    Ove
    Last edited by ovjo12; 2010-07-16 at 15:57.

  2. #2
    Registered User
    Join Date
    Mar 2009
    Posts
    16

    Re: Error message when install Nokia Qt SDK on Mac OS X

    Are you confident that you didn't run out of disk space on the Volume you are installing to?

    Anyway, please report this as a bug at http://bugreports.qt.nokia.com and post the bug ID here for a reference to others.

    Daniel

  3. #3
    Registered User
    Join Date
    Mar 2003
    Location
    Sweden, Stockholm
    Posts
    90

    Re: Error message when install Nokia Qt SDK on Mac OS X

    Quote Originally Posted by danimo View Post
    Are you confident that you didn't run out of disk space on the Volume you are installing to?

    Anyway, please report this as a bug at http://bugreports.qt.nokia.com and post the bug ID here for a reference to others.

    Daniel
    No problem with with disk space and yes I have already report this a bug.

    Earlier I got this answer about build fails in Qt Creator:
    ( http://discussion.forum.nokia.com/fo...-in-Qt-Creator )
    - You need to install "development tools". I think it's part of xcode
    I was thinking, is it also needed to have development tools (xcode) installed before installing Nokia Qt SDK on Mac OS X?
    I will anyway try it soon when I have my install DVD for Mac OS X.

  4. #4
    Nokia Developer Expert
    Join Date
    Jul 2010
    Posts
    2

    Re: Error message when install Nokia Qt SDK on Mac OS X

    Would you please execute the following the following commands and post the output?

    Code:
    cd /Users/ove/NokiaQtSDK/Maemo/4.6.2
    ./postinstall/postinstall.sh

  5. #5
    Registered User
    Join Date
    Mar 2003
    Location
    Sweden, Stockholm
    Posts
    90

    Re: Error message when install Nokia Qt SDK on Mac OS X

    Quote Originally Posted by Jörg Bornemann View Post
    Would you please execute the following the following commands and post the output?

    Code:
    cd /Users/ove/NokiaQtSDK/Maemo/4.6.2
    ./postinstall/postinstall.sh
    ove$ ./postinstall/postinstall.sh
    Creating default target fremantle-pr12 ...
    This may take a while ...
    Target already created, continue to create runtime
    Set default target fremantle-pr12.
    QEMU runtime 'rx51-fremantle-pr12' already exists.
    In case of premature 'rx51-fremantle-pr12' installation enter
    'mad-admin remove rx51-fremantle-pr12' to clear the problem.
    ove$

  6. #6
    Registered User
    Join Date
    Mar 2003
    Location
    Sweden, Stockholm
    Posts
    90

    Re: Error message when install Nokia Qt SDK on Mac OS X

    I also installed Xcode and reinstall Nokia Qt SDK and got same error
    /Ove

  7. #7
    Registered User
    Join Date
    Jul 2010
    Posts
    1

    Re: Error message when install Nokia Qt SDK on Mac OS X

    I can't find the reported bug, so here is another: http://bugreports.qt.nokia.com/browse/QTSDK-146. If you do find it, feel free to mark it as a dupe.

  8. #8
    Registered User
    Join Date
    Mar 2003
    Location
    Sweden, Stockholm
    Posts
    90

    Re: Error message when install Nokia Qt SDK on Mac OS X

    Quote Originally Posted by craigb View Post
    I can't find the reported bug, so here is another: http://bugreports.qt.nokia.com/browse/QTSDK-146. If you do find it, feel free to mark it as a dupe.
    Here my reported bug: http://bugreports.qt.nokia.com/browse/QTSDK-138

    Regards,
    Ove

  9. #9
    Registered User
    Join Date
    Aug 2010
    Posts
    2

    Re: Error message when install Nokia Qt SDK on Mac OS X

    Ouch, why you use a .7z format file ? It may the source of problem isn't it ?
    By the way, I have recently tried to install Online QtSDK install and I had the same error message.

    I have already installed XCode and all Developer tools.

  10. #10
    Nokia Developer Expert
    Join Date
    Jul 2010
    Posts
    2

    Re: Error message when install Nokia Qt SDK on Mac OS X

    Quote Originally Posted by v.mariani View Post
    Ouch, why you use a .7z format file ? It may the source of problem isn't it ?
    By the way, I have recently tried to install Online QtSDK install and I had the same error message.
    What exactly is "the same error message"? The failing postinstall or the failing extraction?

  11. #11
    Nokia Developer Champion
    Join Date
    Feb 2005
    Location
    Campina Grande/PB - Brazil
    Posts
    138

    Re: Error message when install Nokia Qt SDK on Mac OS X

    Hi fellows, I had the same error, but I has been reinstall the Xcode 3.2.3 and iOS SDK 4.0.2 with all options checked (Full Installation) and reinstalled the Nokia Qt SDK, now it's works perfectly.

Similar Threads

  1. Nokia Qt SDK for Mac -- build fails in Qt Creator
    By ovjo12 in forum [Archived] Qt SDKs and Tools
    Replies: 4
    Last Post: 2010-07-19, 15:29
  2. "Pure Qt" SDK cannot live next to Symbian OS specific Qt SDK on a single PC
    By svdwal in forum [Archived] Qt SDKs and Tools
    Replies: 1
    Last Post: 2010-07-06, 07:51
  3. Nokia Qt SDK & Mac support?
    By ovjo12 in forum [Archived] Qt SDKs and Tools
    Replies: 5
    Last Post: 2010-05-02, 16:42
  4. sdk for mac os
    By deskhelp in forum Symbian Tools & SDKs
    Replies: 7
    Last Post: 2010-01-05, 04:10
  5. Replies: 4
    Last Post: 2009-12-07, 18:32

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •