×

Discussion Board

Results 1 to 4 of 4
  1. #1
    Registered User
    Join Date
    Jan 2010
    Posts
    2

    AspectJ - J2ME application running on Nokia n97

    Hi!

    Has anyone achieved to run an AspectJ application on Nokia N97?
    And on the Nokia N97 emulator?

    Mine is successfully running on Java Wireless Toolkit WTK 2.5.2_01 emulator, but I can't get it to work on my N97, not even on the emulator.

    The emulator returns the following error:

    Uncaught exception!
    java.lang.NoClassDefFoundError: org.aspectj.lang.NoAspectBoundException

    Regards

  2. #2
    Super Contributor
    Join Date
    Jun 2003
    Location
    Cheshire, UK
    Posts
    7,395

    Re: AspectJ - J2ME application running on Nokia n97

    Welcome to Forum Nokia!

    You have not included the AspectJ library classes in your JAR file.

    How much luck you will have using AspectJ on mobile, I have no idea. I don't know enough about how Aj is implemented. Any functionality that relies on reflection or run-time byte-code modification is going to be a problem.

    Graham.

  3. #3
    Registered User
    Join Date
    Jan 2010
    Posts
    2

    Re: AspectJ - J2ME application running on Nokia n97

    Yes, I know it seams so, but yes, it is included.
    What I don´t get is how the same application works on WTK 2.5.2_01 and it doesn´t on Nokia n97...

  4. #4
    Super Contributor
    Join Date
    Jun 2003
    Location
    Cheshire, UK
    Posts
    7,395

    Re: AspectJ - J2ME application running on Nokia n97

    The only other reason why you might get that error, is if an attempt is made to initialize a class, after a previous attempt to initialize the same class failed with an exception (thrown from the static{} code).

    Graham.

Similar Threads

  1. AOP - AspectJ for J2ME
    By LarryLobster in forum Mobile Java General
    Replies: 3
    Last Post: 2010-06-03, 06:51
  2. [moved] Nokia N97 SDK not running!!!
    By ZaidShah in forum Mobile Java Tools & SDKs
    Replies: 0
    Last Post: 2009-11-04, 08:03
  3. Nokia 6233 device switches off while running a j2me application
    By colombus2in in forum Mobile Java General
    Replies: 2
    Last Post: 2009-03-23, 05:35
  4. problem running j2me application on Nokia Emulator 60 series
    By chancp in forum Mobile Java Tools & SDKs
    Replies: 0
    Last Post: 2002-07-03, 02:59
  5. problem running j2me application on Nokia Emulator 60 series
    By chancp in forum Mobile Java General
    Replies: 0
    Last Post: 2002-07-03, 02:55

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×