×

Discussion Board

Results 1 to 1 of 1
  1. #1
    Registered User
    Join Date
    May 2010
    Posts
    29

    NOKIA_PATH_JAVASCRIPT and NOKIA_PATH_STYLE_ROOT and another related strange problem

    Hi,

    Problem 1
    -----------------
    I am quite perplexed over the use of this 2 variables in Guarana UI.
    I'm not sure where to put them exactly and why.

    Basically, I have a main function called init() when I have all my code. If I put the variables declaration globally (outside init()'s declaration), it doesn't seem to load the Guarana UI at all.

    but if I place it inside the init(), it works.

    Why is this happening?

    Problem 2
    ------------------
    Also, I am also encountering a very strange problem.

    I was playing with some of the demos, e.g. the ViewManager demo file found in the Guarana UI package. Somehow when I tried to move the file away to another folder even after updating the 4 links (see below), the page won't load. I don't see any other code that has any references to external files or locations.

    Original
    Code:
    <link rel='stylesheet' href='../../themes/themeroller/default-theme/Themeroller.css' type='text/css' media='screen'> 
    <link rel='stylesheet' href='../../themes/nokia/ext-theme/default/360x640/custom.css' type='text/css' media='screen'> 
    <script src='../../lib/jquery/jquery.js' type='text/javascript' charset='utf-8'></script> 
    <script src='../../lib/Guarana.js' type='text/javascript' charset='utf-8'></script>
    to (when I put the file simply in the sub folder, hence the additional ../)
    Code:
    <link rel='stylesheet' href='../../../themes/themeroller/default-theme/Themeroller.css' type='text/css' media='screen'> 
    <link rel='stylesheet' href='../../../themes/nokia/ext-theme/default/360x640/custom.css' type='text/css' media='screen'> 
    <script src='../../../lib/jquery/jquery.js' type='text/javascript' charset='utf-8'></script> 
    <script src='../../../lib/Guarana.js' type='text/javascript' charset='utf-8'></script>
    The path is correct because the CSS is loaded, but the code doesnt.
    Why is it so strange?

    I tried putting alert() codes around the functions and I realise nothing happens when it encounters Nokia objects (e.g. Nokia.use()).

    Update: I realise that it will work outside of the \demo folder once i insert the path to the lib and themes folder in JS:
    Code:
    	NOKIA_PATH_JAVASCRIPT = '../GuaranaFiles/lib/';
    	NOKIA_PATH_STYLE_ROOT = '../GuaranaFiles/themes/nokia/base/';
    but why? Its not even in the demo file!
    Last edited by Aimevous; 2010-07-20 at 12:03. Reason: update

Similar Threads

  1. Strange problem related to QtMobility package
    By anand_trex in forum [Archived] Qt Mobility Project
    Replies: 0
    Last Post: 2010-03-17, 13:02
  2. Form related Problem.....
    By sunil304047 in forum Symbian
    Replies: 4
    Last Post: 2008-12-16, 10:42
  3. emulator related problem
    By deepakk in forum Symbian
    Replies: 2
    Last Post: 2008-03-20, 16:32
  4. File Related Problem???????
    By chandantheracer in forum Symbian User Interface
    Replies: 0
    Last Post: 2007-06-11, 08:58
  5. problem related to RMS
    By giridharg in forum Mobile Java General
    Replies: 0
    Last Post: 2005-12-19, 12:32

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×