×

Discussion Board

Results 1 to 5 of 5
  1. #1
    Registered User
    Join Date
    Mar 2003
    Location
    Sweden, Stockholm
    Posts
    90

    Question fail to deploy to N900 from Nokia Qt SDK for Mac in Qt Creator

    I installed Nokia Qt SDK for Mac, when I open a example project and try to deploy it in Qt Creator I get this error message:
    Cleaning up remote leftovers first ...
    Error running initial cleanup: Could not connect to host.

    I have added a "Maemo device Configuration" but if I run "Test" I also get this error message:
    Device configuration test failed:
    Could not connect to host.

    What to do?
    I have connect my N900 using USB and choose "PC Suite"

    Regards,
    Ove
    Last edited by ovjo12; 2010-07-22 at 13:44.

  2. #2
    Super Contributor
    Join Date
    Oct 2009
    Posts
    4,326

    Re: fail to deploy from Nokia Qt SDK for Mac in Qt Creator

    Quote Originally Posted by ovjo12 View Post
    I have connect my N900 using USB and choose "PC Suite
    Were you following this document?
    http://doc.qt.nokia.com/nokia-qtsdk-...ing-maemo.html

  3. #3
    Registered User
    Join Date
    Mar 2003
    Location
    Sweden, Stockholm
    Posts
    90

    Re: fail to deploy from Nokia Qt SDK for Mac in Qt Creator

    Read in the Qt SDK Documentation I also have to install Mad Developer on my device (N900).
    I did that but I haven't manage to get it working.
    - First I installed Mad Developer
    - Then I have set up the USB settings, click Edit on the usb0 row and confirm by clicking Configure.
    - After that I select Developer Password to generate a password for a freshly created user called developer.
    - I also enter the password when I configure the connection in Qt Creator.
    - I have also added a "Maemo device Configuration" but if I run "Test" it fail I get this error:
    Device configuration test failed:
    Could not connect to host.

  4. #4
    Registered User
    Join Date
    Mar 2003
    Location
    Sweden, Stockholm
    Posts
    90

    Re: fail to deploy from Nokia Qt SDK for Mac in Qt Creator

    I now manage to get it working!
    I used the link: http://wiki.maemo.org/N900_USB_networking#Mac_OS_X
    The problem was this:
    To use the Internet connection of your Mac via USB networking make sure to enable System Preferences -> Sharing -> Internet sharing for the N900 interface:

    I did this:
    1) Choose Apple > System Preferences, and then click Sharing.
    2) Choose Internet sharing
    3) Choose a network service from the “Share your connection from” pop-up menu, choose "Ethernet"
    4) Select a networking service to share your Internet connection from the “To computers using” list, choose "N900(PC Suite Mode)

    Now it is working!!

  5. #5
    Registered User
    Join Date
    Mar 2003
    Location
    Sweden, Stockholm
    Posts
    90

    Re: fail to deploy from Nokia Qt SDK for Mac in Qt Creator

    But I found out that Mac via USB networking not working so often, then I configure using wifi instead.
    Then when I start Mad Developer, I see the IP-adress. I change to this new IP-adress in "Maemo device Configuration".

Similar Threads

  1. Nokia Qt SDK for Mac -- build fails in Qt Creator
    By ovjo12 in forum [Archived] Qt SDKs and Tools
    Replies: 4
    Last Post: 2010-07-19, 15:29
  2. QT Blutooth module not available in Nokia QT SDK (QT 4.6.3)
    By Suyash in forum [Archived] Qt SDKs and Tools
    Replies: 5
    Last Post: 2010-06-25, 09:55
  3. Nokia Qt SDK: Qt Creator and Resources?
    By mitts in forum [Archived] Qt SDKs and Tools
    Replies: 2
    Last Post: 2010-06-20, 11:14
  4. QT Nokia sdk installation and QT Creator config problem
    By kapiluiet in forum [Archived] Qt SDKs and Tools
    Replies: 1
    Last Post: 2010-06-02, 13:49
  5. Nokia Qt SDK & Mac support?
    By ovjo12 in forum [Archived] Qt SDKs and Tools
    Replies: 5
    Last Post: 2010-05-02, 16:42

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×