×

Discussion Board

Results 1 to 9 of 9

Hybrid View

  1. #1
    Registered User
    Join Date
    Apr 2008
    Posts
    11

    NokiaQtSDK Simultor build problem on Ubuntu 10.04

    Hi all,

    I am trying to build a sample app on Ubuntu using NokiaQtSDK 1.0 for Qt Simulator as build configuration. Unfortunately I am getting build error, where as Desktop build is successful. I tried to add <mypath>/NokiaQtSDK/Simulator/Qt/gcc/lib to Library path, but still unsuccessful with build. Here I am posting my console output. May be it is silly issue, but I am quite new to Linux platform and serious about developing on Ubuntu with Nokia Qt SDK only. Any help is much appreciated



    Running build steps for project testapp1...
    Starting: "/home/srikanth/NokiaQtSDK/Simulator/Qt/gcc/bin/qmake" /home/srikanth/testapp1/testapp1.pro -r -spec linux-g++
    The process "/home/srikanth/NokiaQtSDK/Simulator/Qt/gcc/bin/qmake" exited normally.
    Starting: "/usr/bin/make" -w
    make: Entering directory `/home/srikanth/testapp1-build-simulator'
    /home/srikanth/NokiaQtSDK/Simulator/Qt/gcc/bin/uic ../testapp1/mainwindow.ui -o ui_mainwindow.h
    g++ -c -pipe -g -Wall -W -D_REENTRANT -DQT_NO_PRINTER -DQT_GUI_LIB -DQT_CORE_LIB -DQT_SHARED -I../NokiaQtSDK/Simulator/Qt/gcc/mkspecs/linux-g++ -I../testapp1 -I../NokiaQtSDK/Simulator/Qt/gcc/include/QtCore -I../NokiaQtSDK/Simulator/Qt/gcc/include/QtGui -I../NokiaQtSDK/Simulator/Qt/gcc/include -I. -I. -I../testapp1 -I. -o main.o ../testapp1/main.cpp
    g++ -c -pipe -g -Wall -W -D_REENTRANT -DQT_NO_PRINTER -DQT_GUI_LIB -DQT_CORE_LIB -DQT_SHARED -I../NokiaQtSDK/Simulator/Qt/gcc/mkspecs/linux-g++ -I../testapp1 -I../NokiaQtSDK/Simulator/Qt/gcc/include/QtCore -I../NokiaQtSDK/Simulator/Qt/gcc/include/QtGui -I../NokiaQtSDK/Simulator/Qt/gcc/include -I. -I. -I../testapp1 -I. -o mainwindow.o ../testapp1/mainwindow.cpp
    /home/srikanth/NokiaQtSDK/Simulator/Qt/gcc/bin/moc -DQT_NO_PRINTER -DQT_GUI_LIB -DQT_CORE_LIB -DQT_SHARED -I../NokiaQtSDK/Simulator/Qt/gcc/mkspecs/linux-g++ -I../testapp1 -I../NokiaQtSDK/Simulator/Qt/gcc/include/QtCore -I../NokiaQtSDK/Simulator/Qt/gcc/include/QtGui -I../NokiaQtSDK/Simulator/Qt/gcc/include -I. -I. -I../testapp1 -I. ../testapp1/mainwindow.h -o moc_mainwindow.cpp
    g++ -c -pipe -g -Wall -W -D_REENTRANT -DQT_NO_PRINTER -DQT_GUI_LIB -DQT_CORE_LIB -DQT_SHARED -I../NokiaQtSDK/Simulator/Qt/gcc/mkspecs/linux-g++ -I../testapp1 -I../NokiaQtSDK/Simulator/Qt/gcc/include/QtCore -I../NokiaQtSDK/Simulator/Qt/gcc/include/QtGui -I../NokiaQtSDK/Simulator/Qt/gcc/include -I. -I. -I../testapp1 -I. -o moc_mainwindow.o moc_mainwindow.cpp
    g++ -Wl,-rpath,/home/srikanth/NokiaQtSDK/Simulator/Qt/gcc/lib -o testapp1 main.o mainwindow.o moc_mainwindow.o -L/home/srikanth/NokiaQtSDK/Simulator/Qt/gcc/lib -lQtGui -L/home/srikanth/NokiaQtSDK/Simulator/Qt/gcc/lib -L/usr/X11R6/lib -lQtNetwork -lQtCore -lpthread
    /usr/bin/ld: skipping incompatible /home/srikanth/NokiaQtSDK/Simulator/Qt/gcc/lib/libQtGui.so when searching for -lQtGui
    /usr/bin/ld: skipping incompatible /home/srikanth/NokiaQtSDK/Simulator/Qt/gcc/lib/libQtGui.so when searching for -lQtGui
    /usr/bin/ld: skipping incompatible /home/srikanth/NokiaQtSDK/Simulator/Qt/gcc/lib/libQtNetwork.so when searching for -lQtNetwork
    /usr/bin/ld: skipping incompatible /home/srikanth/NokiaQtSDK/Simulator/Qt/gcc/lib/libQtNetwork.so when searching for -lQtNetwork
    /usr/bin/ld: skipping incompatible /home/srikanth/NokiaQtSDK/Simulator/Qt/gcc/lib/libQtCore.so when searching for -lQtCore
    /usr/bin/ld: skipping incompatible /home/srikanth/NokiaQtSDK/Simulator/Qt/gcc/lib/libQtCore.so when searching for -lQtCore
    main.o: In function `main':
    /home/srikanth/testapp1-build-simulator/../testapp1/main.cpp:8: undefined reference to `QWidget::show()'
    collect2: ld returned 1 exit status
    make: Leaving directory `/home/srikanth/testapp1-build-simulator'
    make: *** [testapp1] Error 1
    The process "/usr/bin/make" exited with code %2.
    Error while building project testapp1 (target: Qt Simulator)
    When executing build step 'Make'

  2. #2
    Super Contributor
    Join Date
    Oct 2009
    Posts
    4,326

    Re: NokiaQtSDK Simultor build problem on Ubuntu 10.04

    Libraries shipped with Qt Simulator for some reason are not compatible with your platform. Were installation of Nokia Qt SDK complete?
    Just in case try make distclean and rebuild the project.

  3. #3
    Registered User
    Join Date
    Apr 2008
    Posts
    11

    Re: NokiaQtSDK Simultor build problem on Ubuntu 10.04

    No notable errors during installation except a .sh script error for Maemo (I hope it doest have anything to do with QtLibs). NokiaQtSDK dint work out of box on first run. It reported linking errors that it cant find libQtGui etc. I hope they should be installed with NokiaQtSDK. Then I have to do a manual installation of Qt4libs as

    sudo apt-get install libqt4-dev
    then relevent libs are installed in /usr/bin

    After manual installation Desktop build is sucessful, but not Qt Simulator build. What is understand is libs installed by NokiaQtSDK are not picked up for some reason. Correct me if I am wrong, and any help is much appreciated

    By the way I installed NokiaQtSDK 32bit version on 32bit machine.

    - Srikanth

  4. #4
    Super Contributor
    Join Date
    Oct 2009
    Posts
    4,326

    Re: NokiaQtSDK Simultor build problem on Ubuntu 10.04

    Quote Originally Posted by srikanthsombhatla View Post
    sudo apt-get install libqt4-dev
    then relevent libs are installed in /usr/bin

    After manual installation Desktop build is sucessful, but not Qt Simulator build.
    This has no effect on Qt Simulator as it uses it's own copy of Qt libraries. I suggest you to remove and install SDK again.

  5. #5
    Registered User
    Join Date
    Apr 2008
    Posts
    11

    Re: NokiaQtSDK Simultor build problem on Ubuntu 10.04

    Uninstalled SDK using the supplied maintainance tool and reinstalled it, but problem exists.
    I suspect the same as you pointed that NokiaQtSDK uses its own libs. But as i pasted in the first thread, it is picking the correct qmake of NokiaQtSDk, but not the libraries. Any sugesstions are helpfull.

  6. #6
    Registered User
    Join Date
    Apr 2008
    Posts
    11

    Re: NokiaQtSDK Simultor build problem on Ubuntu 10.04

    In the installed folder of NokiaQtSDK i could find only the folder with the name Simulator, but not any folder that has pure Qt libs. So the basic questions - If I install only NokiaQtSDK (no Qt SDK exists in my ubuntu 10.04 system) can I develop for linux desktop and other nokia platforms (Maemo, Symbian - i understand remote compiler stuff)?
    OR
    Should I install a dektop Qt version and then install NokiaQtSDK?

    Any help is really appreciated. Thanks in advance.

  7. #7
    Super Contributor
    Join Date
    Dec 2005
    Location
    England,UK
    Posts
    1,600

    Re: NokiaQtSDK Simultor build problem on Ubuntu 10.04

    Quote Originally Posted by srikanthsombhatla View Post
    .
    .
    sudo apt-get install libqt4-dev
    .
    - Srikanth
    This will cause lots of problems doing this there is lots of incompatibility with early versions of Qt4

    I believe this might be version Qt 4.5 !!!.
    do the following command
    sudo apt-get remove libqt4-dev

    Then download Qt X11 Desktop from Qt SDK for Open Source C++ development on Linux/X11 32-bit

    chmod u+x qt-sdk-linux-x86-opensource-2010.04.bin
    you should now be able to execute the file as normal. You can do this from the command line by typing:

    ./qt-sdk-linux-x86-opensource-2010.04.bin
    This could be installed under a separate username if you want to keep them apart as this installs another version of Qt Creator and this will be confusing for you.
    Thanks,
    Jim

  8. #8
    Registered User
    Join Date
    Apr 2008
    Posts
    11

    Re: NokiaQtSDK Simultor build problem on Ubuntu 10.04

    Last edited by srikanthsombhatla; 2010-08-24 at 08:05. Reason: SOLVED

Similar Threads

  1. can not install Nokia Qt beta on Ubuntu 9.10
    By stone.chao in forum [Archived] Qt SDKs and Tools
    Replies: 2
    Last Post: 2010-06-07, 16:27
  2. Upgrading firmware Ubuntu 9.04
    By Plitter in forum General Development Questions
    Replies: 1
    Last Post: 2009-07-20, 16:48
  3. Using Nokia S60 3rd from Ubuntu 8.04
    By FBulovic in forum News and Announcements
    Replies: 2
    Last Post: 2008-11-09, 00:31
  4. Bugs on 9500 Firmware V 04.51(04) with Arabic support
    By WeArab in forum General Development Questions
    Replies: 1
    Last Post: 2005-10-18, 14:57
  5. SDK build 10 problems.
    By topisystems in forum Multimodecards
    Replies: 1
    Last Post: 2002-09-24, 14:03

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×