×

Discussion Board

Results 1 to 2 of 2
  1. #1
    Super Contributor
    Join Date
    Mar 2003
    Posts
    1,733

    Reinstalling a newly compile servlet

    Posted by Neil Wilkinson, neilmw@totalise.co.uk
    on February 06, 2002 at 12:25

    Does anyone know how to reinstall a servlet that you've just re-compiled. Using the 'Reload' command doesn't load the new version of the servlet. I'm having to reboot the machine to make NAS use the new one. I've tried shutting down then restarting the cluster/server core etc., but it still uses the old version.

  2. #2
    Super Contributor
    Join Date
    Mar 2003
    Posts
    1,733

    RE: Reinstalling a newly compile servlet

    Posted by Lars Ellmer, lars.ellmer@smsg.cc
    on February 15, 2002 at 12:38

    If you restart the server it certainly uses a new version of your servlet. If this doesn't happen it seems like you have a compile error in your servlet and it doesn't rebuild the class file. For testing it delete the old class file and recompile again. If the class file reappears everthing is ok. Otherwise check your code.
    If it reapears and after shutting down the NACS and restarting it the servlet is still there ... remove the servlet from the servlet list and add it again ... that should work 100% for sure ...especially shutting down the NACS and restarting it. I done it a thousand times. DO NOT USE THIS install as a service possiblility as then the server won't unload totally and you may get stuck in that. Basically, especially for development, it also makes more sense to see the console window output on the activ server window for debugging.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •