×

Discussion Board

Results 1 to 4 of 4
  1. #1
    Regular Contributor
    Join Date
    Aug 2004
    Posts
    113

    Unhappy Installing QtMobility 1.0.2 on a Win system

    Hey guys,

    I'm having some mixed results from installing QtMobility 1.0.2 and I wanted to check up if what I'm doing is correct.

    First of all, I have the Qt Nokia SDK, it included QtMobility, I've updated it to 1.0.1 using the "Maintain Nokia Qt SDK" app and so far things have been doing ok. Or at least that's what I think.

    I wanted to install the latest 1.0.2 release of QtMobility, I followed these instructions in order to do so:

    http://wiki.forum.nokia.com/index.ph...t_Mobility_API

    So far I was able to have it running on the cellphone by installing QtMobility_Express_Signed.sis directly on it, and Qt Creator seems to detect my settings. The only problem is that it doesn't work on the Simulator.

    Then, I find another set of how to install instructions:
    http://doc.trolltech.com/qtmobility-...tallation.html

    First of all, the "Bulding for Symbian on Windows" section says:
    Building Qt Mobility for Symbian is not necessary as the package contains pre-built binaries for the SDK and SIS file for the device. See the symbian\install.txt file on how to deploy these.
    Which is incorrect since there're no pre-built binaries for the SDK anywhere.

    Second, running the configure.bat (using the Qt for Symbian command prompt) gives me these results at the beginning:

    Code:
    c:\Nokia\QtSDK\QtMobility\qt-mobility-symbian-opensource-1.0.2>configure
    c:\Nokia\QtSDK\QtMobility\qt-mobility-symbian-opensource-1.0.2
    Checking available Qt
    4.6.3
    Checking make
    ... Symbian abld make found.
    
    Start of compile tests
    Checking Audiorouting_s60
    ... Not Found
    Checking Tunerlibrary_for_3.1
    ... Not Found
    Checking RadioUtility_for_post_3.1
    ... Not Found
    Checking OpenMaxAl_support
    ... Not Found
    Checking Surfaces_s60
    ... Not Found
    etcetera... (everything it checks returns a Not Found)

    And lastly, every time I try to use multimedia's libs from QtMobility they work fine on the device (I can play audio using QMediaPlayer), but the simulator will always throw:

    defaultServiceProvider::requestService(): no service found for - "com.nokia.qt.mediaplayer"

    So testing is kind of a pain since compiling for the device takes years.

    Why things have to be always sooo difficult? I just wanna code

    Please, if anyone can shed some light into correctly installing QtMobility I would really appreciate it.

    Best!
    Matias

  2. #2
    Regular Contributor
    Join Date
    Jun 2010
    Posts
    73

    Re: Installing QtMobility 1.0.2 on a Win system

    Me to!

    Cheers, Luki

  3. #3
    Registered User
    Join Date
    Jul 2009
    Posts
    46

    Re: Installing QtMobility 1.0.2 on a Win system

    I am also getting the same message when using the simulator. So it's not possible to get a QMediaPlayerControl from QMediaPlayer.

  4. #4
    Regular Contributor
    Join Date
    May 2007
    Posts
    468

    Re: Installing QtMobility 1.0.2 on a Win system

    Hi,
    if you update mobility to Nokia Qt SDK "manually" the simulator might not work be able to support it. You should wait for the official updates through "update Nokia Qt SDK". The 1.0.2 is now available as is updated simulator version.

    Generally if you want to try out something that's not yet officially supported in Nokia Qt SDK I would recommend using a separate Symbian SDK, just to ensure you don't mess up your nokia Qt sdk setup.

    One more thing, in the future we'll try to align the releases better i.e get those available for Nokia Qt SDK immediately when published. Technology previews and beta versions might not be available for Nokia Qt SDK, for "early adopters" I'd recommend the separate Symbian SDK approach.

    Cheers,
    Jack

Similar Threads

  1. Error with QtMobility 1.0 after succesfully intall QtMobility tp2
    By Estel in forum [Archived] Qt Mobility Project
    Replies: 0
    Last Post: 2010-06-21, 21:21
  2. Installing qtmobility sms application fails in N95
    By Miksa__ in forum [Archived] Qt Mobility Project
    Replies: 1
    Last Post: 2010-06-12, 20:49
  3. installing QTMobility application on Target
    By prathibha83 in forum [Archived] Qt Mobility Project
    Replies: 2
    Last Post: 2010-05-12, 13:00
  4. Installing D211 on a Win CE 3.0 WebPad (StrongARM)
    By gilliesf in forum Multimodecards
    Replies: 4
    Last Post: 2002-09-26, 08:37
  5. Win NT 4.0 vs WIN 95/98 operating system
    By vuorte in forum Symbian Tools & SDKs
    Replies: 1
    Last Post: 2002-08-28, 09:56

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×