×

Discussion Board

Results 1 to 3 of 3
  1. #1
    Registered User
    Join Date
    Aug 2010
    Posts
    2

    problem with radio project - qt mobilty radio project

    hi,

    i'm trying to run the radio application given in this link : http://doc.trolltech.com/qtmobility-1.0/radio.html

    i used qt creator 4.6 to run this program.
    It gave no compilation issues.

    But, wen i try it on simulator,
    it gives this message :

    defaultServiceProvider::requestService(): no service found for - "com.nokia.qt.radio"
    Its running on the simulator , but not a operating radio. It simply displays the UI. with the message: "No radio found "

    why is this so?

    Help..!

  2. #2
    Super Contributor
    Join Date
    Mar 2009
    Posts
    1,024

    Re: problem with radio project - qt mobilty radio project

    Simulator doesn't emulate the hardware.

  3. #3
    Regular Contributor
    Join Date
    Jun 2010
    Posts
    73

    Re: problem with radio project - qt mobilty radio project

    You have to test it on a real device, because the simulator does not yet work with sound.

Similar Threads

  1. Qt Creator 2.0 project settings problem
    By favoritas37 in forum [Archived] Qt SDKs and Tools
    Replies: 3
    Last Post: 2010-06-29, 14:52
  2. Not able to initialize radio thru Radio Utility API
    By kamaljaiswal in forum Symbian
    Replies: 2
    Last Post: 2010-04-15, 07:14
  3. Replies: 1
    Last Post: 2008-05-14, 17:08
  4. Replies: 1
    Last Post: 2007-09-04, 08:21

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×