×

Discussion Board

Results 1 to 5 of 5
  1. #1
    Registered User
    Join Date
    Feb 2010
    Posts
    3

    System Error in Device

    I created an application. It works fine in Simulator.
    But When the application is installed and opened in device .A dialog appears,
    "System Error !"

    Please, can anyone help me.

  2. #2
    Super Contributor
    Join Date
    Mar 2004
    Location
    Singapore
    Posts
    9,968

    Re: System Error in Device

    Try enabling Extended panic then the system error will come with a Panic code. which will help in solving you problem.

  3. #3
    Nokia Developer Moderator
    Join Date
    Oct 2006
    Location
    Finland
    Posts
    4,540

    Re: System Error in Device

    Quote Originally Posted by neeraj17sep.ims@gmail.com View Post
    I created an application. It works fine in Simulator.
    But When the application is installed and opened in device .A dialog appears,
    "System Error !"

    Please, can anyone help me.
    Ofcourse enabling the extended panic code is the right approach fo the system error kind of issues. But you could also try to check if you have packaged all the needed sources (More frequently forgotten are the 'extras' or the data needed like some xml file etc), and are the sources placed in the right destinations.

  4. #4
    Registered User
    Join Date
    Feb 2010
    Posts
    3

    Re: System Error in Device

    First in my code, System Error -1 is coming due to misplaced file.
    When i check it and solved.

    Then System Error occurs without code.
    I tried extended panic code, but it doesn't solved my problem, because it does not give any code.

  5. #5
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,689

    Re: System Error in Device

    System Error without error code is often caused by mismatching UID-s (the one in the .mmp file and the one returned in AppDllUid, but you may want to check the _reg.rss too)

Similar Threads

  1. Getting system error -1 in device
    By vicky_nits in forum Symbian
    Replies: 2
    Last Post: 2010-07-13, 09:58
  2. Replies: 2
    Last Post: 2009-04-03, 07:20
  3. system error(-1) on device
    By RB_Sahu in forum Symbian
    Replies: 22
    Last Post: 2008-10-12, 11:24
  4. Server sending device information, system error
    By cursed in forum OMA DM/DS/CP
    Replies: 0
    Last Post: 2008-05-12, 11:28
  5. device discovery system error, help
    By jugnoyasir in forum Symbian Networking & Messaging (Closed)
    Replies: 8
    Last Post: 2005-07-05, 04:15

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×