×

Discussion Board

Page 1 of 2 12 LastLast
Results 1 to 15 of 16
  1. #1
    Regular Contributor
    Join Date
    Feb 2008
    Posts
    118

    API Bridge plugin installation problem

    Hi,
    I have created a sample apibridge plugin and a widget for invoking that plugin.
    It is working fine on emulator. I have created sis using wgzinstaller sample app provided in API Bridge package. But when i try to install it on device i get error ' Required application access not granted'.
    I have tried commenting lines of LIB , rsc and DLL transfer, then it gets installed.
    Whats the problem with lib and Dll installation ?

    Here is the content of PKG file :


    ; Installation file for Symbian OS 9.x for generic console application
    ; Installation file for WidgetInstaller EXE
    ;
    ; This is an auto-generated PKG file by Carbide.
    ; This file uses variables specific to Carbide builds that will not work
    ; on command-line builds. If you want to use this generated PKG file from the
    ; command-line tools you will need to modify the variables with the appropriate
    ; values: $(EPOCROOT), $(PLATFORM), $(TARGET)
    ;

    &EN

    ;
    ; UID is the exe's UID
    ;
    #{"Sample App"},(UID),1,0,0

    ;Localised Vendor name
    %{"Nokia"}

    ;Unique Vendor name
    :"Nokia"

    ;Supports S60 3rd&5rd Editions
    [0x101F7961], 0, 0, 0, {"S60 3rd Edition"}
    [0x102032BE], 0, 0, 0, {"S60 3rd Edition, FP1"}
    [0x102752AE], 0, 0, 0, {"S60 3rd Edition, FP2"}
    [0x1028315F], 0, 0, 0, {"S60 5th Edition"}


    ;plugin resource
    "$(EPOCROOT)Epoc32\data\z\resource\plugins\TestDllApp_UID.rsc" - "C:\Resource\Plugins\TestDllApp_UID.rsc"
    ;support lib
    "D:\S60\devices\S60_5th_Edition_SDK_v1.0\epoc32\release\winscw\udeb\Test.lib" -"!:\sys\bin\test.lib"
    ;api bridge plugin DLL
    "D:\S60\devices\S60_5th_Edition_SDK_v1.0\epoc32\release\winscw\udeb\TestDll_UID.dll" -"!:\sys\bin\TestDll_UID.dll"


    ;Embed APIBridge and set Dependency
    @"..\content\APIBridge_v1_1.sis", (0x2002373F)
    (0x2002373F), 1, 1, 0, {"APIBridge"}

    ;Add here any additional files or other embedded sis files

    ;Here goes the widget - Note: The destination directory should be d:\WgzInstaller\

    "..\content\MyWidget.wgz" -"d:\WgzInstaller\MyWidget.wgz"

    ;Installer files


    "$(EPOCROOT)Epoc32\release\$(PLATFORM)\$(TARGET)\WgzInstaller.exe" -"D:\sys\bin\WgzInstaller.exe", FR, RI

  2. #2
    Super Contributor
    Join Date
    Mar 2004
    Location
    Singapore
    Posts
    9,968

    Re: API Bridge plugin installation problem

    "D:\S60\devices\S60_5th_Edition_SDK_v1.0\epoc32\release\winscw\udeb\Test.lib" -"!:\sys\bin\test.lib"
    why you are trying to install a lib file to device also can you show your mmp file ?

  3. #3
    Regular Contributor
    Join Date
    Feb 2008
    Posts
    118

    Re: API Bridge plugin installation problem

    I have created the lib and invoked some methods from lib file in plugin Dll , does it required to be installed on device ??

  4. #4
    Regular Contributor
    Join Date
    Feb 2008
    Posts
    118

    Re: API Bridge plugin installation problem

    Even if I commented that lib installation line i get same error.

  5. #5
    Super Contributor
    Join Date
    Mar 2004
    Location
    Singapore
    Posts
    9,968

    Re: API Bridge plugin installation problem

    can we see your mmp file.

  6. #6
    Super Contributor
    Join Date
    Mar 2004
    Location
    Singapore
    Posts
    9,968

    Re: API Bridge plugin installation problem

    Quote Originally Posted by swarupk2007 View Post
    I have created the lib and invoked some methods from lib file in plugin Dll , does it required to be installed on device ??
    are you sure you need to put the lib in device as it is not a excuatable file. only DLL with required exe will do.

  7. #7
    Regular Contributor
    Join Date
    Feb 2008
    Posts
    118

    Re: API Bridge plugin installation problem

    This is the content of mmp file of Apibridge plugin and widget installer :

    TARGET WgzInstaller.exe
    TARGETTYPE exe
    //TODO: Your UID2 here should replace 0x12345678
    UID 0 0x12345678

    CAPABILITY LocalServices Location NetworkServices ReadUserData UserEnvironment WriteUserData ProtServ


    USERINCLUDE ..\inc
    SYSTEMINCLUDE \epoc32\include

    SOURCEPATH ..\src
    SOURCE WgzInstaller.cpp

    LIBRARY euser.lib
    LIBRARY SWInstCli.lib efsrv.lib

    #ifdef ENABLE_ABIV2_MODE
    DEBUGGABLE_UDEBONLY
    #endif

  8. #8
    Super Contributor
    Join Date
    Mar 2004
    Location
    Singapore
    Posts
    9,968

    Re: API Bridge plugin installation problem

    Quote Originally Posted by swarupk2007 View Post
    This is the content of mmp file of Apibridge plugin and widget installer :

    TARGET WgzInstaller.exe
    TARGETTYPE exe
    //TODO: Your UID2 here should replace 0x12345678
    UID 0 0x12345678

    CAPABILITY LocalServices Location NetworkServices ReadUserData UserEnvironment WriteUserData ProtServ


    USERINCLUDE ..\inc
    SYSTEMINCLUDE \epoc32\include

    SOURCEPATH ..\src
    SOURCE WgzInstaller.cpp

    LIBRARY euser.lib
    LIBRARY SWInstCli.lib efsrv.lib

    #ifdef ENABLE_ABIV2_MODE
    DEBUGGABLE_UDEBONLY
    #endif
    which device you are installing ?

  9. #9
    Super Contributor
    Join Date
    Mar 2004
    Location
    Singapore
    Posts
    9,968

    Re: API Bridge plugin installation problem

    Also why in d drive of device ?
    "$(EPOCROOT)Epoc32\release\$(PLATFORM)\$(TARGET)\WgzInstaller.exe" -"D:\sys\bin\WgzInstaller.exe", FR, RI

  10. #10
    Regular Contributor
    Join Date
    Feb 2008
    Posts
    118

    Re: API Bridge plugin installation problem

    I am installing it on 5th edition phone n97. In d drive of device because sample app is having that as destination path and suggested not to change that as stated in comment :

    ;Here goes the widget - Note: The destination directory should be d:\WgzInstaller\

  11. #11
    Super Contributor
    Join Date
    Mar 2004
    Location
    Singapore
    Posts
    9,968

    Re: API Bridge plugin installation problem

    you have to do a OpenSigning at least you can't use self-Sign as you are embedding a signed sis.

  12. #12
    Regular Contributor
    Join Date
    Feb 2008
    Posts
    118

    Re: API Bridge plugin installation problem

    I am using certificate for signing which is valid. I am getting error 'unable to install' on 5th edition and access error on 3rd edition.
    However code is written and compiled for 5th edition. As per the documents provided for API Bridge it should work, as nothing is mentioned about requiring special capabilities for installing the plugin on device. Also another non plugin app which installs dlls on sys\bin\ path is also signed using same certificate and not having installation issue.
    If anyone knows about API Bridge plugin installation please reply.....

  13. #13
    Super Contributor
    Join Date
    Mar 2004
    Location
    Singapore
    Posts
    9,968

    Re: API Bridge plugin installation problem

    #{"Sample App"},(UID),1,0,0
    i assume you have not added the UID value here ?

  14. #14
    Regular Contributor
    Join Date
    Feb 2008
    Posts
    118

    Re: API Bridge plugin installation problem

    Quote Originally Posted by skumar_rao View Post
    i assume you have not added the UID value here ?
    No i have removed the actual UID from this post

  15. #15
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,684

    Re: API Bridge plugin installation problem

    Are you building the application for GCCE UREL target?

Similar Threads

  1. Dll debug - bridge plugin
    By Christophe.A in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 0
    Last Post: 2010-04-22, 12:41
  2. Flash lite api bridge - capture image problem
    By kinski76 in forum [Archived] Flash Lite on Nokia Devices
    Replies: 4
    Last Post: 2010-02-22, 21:47
  3. Open C/C++ plugin installation problem
    By iyedb in forum Symbian Tools & SDKs
    Replies: 2
    Last Post: 2009-11-23, 09:28
  4. Replies: 3
    Last Post: 2009-09-15, 09:51
  5. SIP Plugin 4.0 installation problem
    By ericvids in forum Symbian Tools & SDKs
    Replies: 2
    Last Post: 2006-12-15, 02:26

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×