×

Discussion Board

Results 1 to 8 of 8
  1. #1
    Regular Contributor
    Join Date
    Jul 2010
    Posts
    66

    Install 1.1.0 TP1 on symbian device

    Hi

    I have downloaded the 1.1 TP, and succesfully configured and built it.

    My question now is that I have a problem running applications compiled with 1.1 on my device, and can't seem to find any Symbian sis file for 1.1.

    How do I build the sis files for 1.1. TP?

    Best regards
    /Anders

  2. #2
    Registered User
    Join Date
    Apr 2009
    Posts
    506

    Re: Install 1.1.0 TP1 on symbian device

    Quote Originally Posted by ankhansen View Post
    How do I build the sis files for 1.1. TP?
    welcome to the club
    Symbian & Qt developer. http://vladest.org

  3. #3
    Registered User
    Join Date
    Aug 2010
    Posts
    11

    Re: Install 1.1.0 TP1 on symbian device

    I faced same problem as your. manage to get it run - Hope this help - http://bananacoding.com/blog/archive...hard-part.aspx

  4. #4
    Registered User
    Join Date
    Nov 2009
    Posts
    26

    Re: Install 1.1.0 TP1 on symbian device

    hm, i'm facing the same problem here.
    how can i build the sis package for symbian device?

    i tried configure, make and makesis with the pkgs.
    any ideas?

  5. #5
    Regular Contributor
    Join Date
    Jul 2010
    Posts
    66

    Re: Install 1.1.0 TP1 on symbian device

    Hi Cubik,

    From the maillist I got the following answer. That at least produces the sis file, I still have some trouble executing applications on my device.

    But in short, in a prompt, enter your qtmobility TP1 directory and do the following:
    cd src\s60installs
    make sis

    Pasted the mail reply from Antti below

    Best regards
    /Anders

    Hi,

    Building sis is easy if your development env is ok. Remember that 1.1 is not officially released and it is being developed on so expect some problems.

    First get a qt mobility codes, then in root level do:

    configure -modules "multimedia location xxx" #tweak to get all the modules you need, leave -modules option out to compile them all
    make release-gcce #or make release-armv5 if you have arm compiler.
    cd src\s60installs\
    make sis # produces qtmobility.sis

    But then the sis signing part. All the api module / backend dll:s need some cababilitys to work. default for dll in the codes is ALL-TCB which will require a special certificate which you don't probably have. So you might need to tweak those dll caps to get dll signed and installed on phone.

    For example multimedia cabas you have to tweak following pro files BEFORE configuring (configure runs qmake which will produces symbian mmp files for the project)

    modules (api ) dll
    src\multimedia\multimedia.pro:
    ..
    symbian {
    load(data_caging_paths)
    QtMediaDeployment.sources = QtMultimediaKit.dll
    QtMediaDeployment.path = /sys/bin
    DEPLOYMENT += QtMediaDeployment
    TARGET.UID3=0x2002AC77
    TARGET.CAPABILITY = ALL -TCB # Edit this for your needs, remember that dll cabas need to be equal or greater that the dll/lib it uses internally
    LIBS += -lefsrv
    }
    ...
    backend plugin dll,
    plugins\multimedia\symbian\mmf\mmf.pro
    ...

    load(data_caging_paths)
    TARGET.EPOCALLOWDLLDATA = 1
    TARGET.UID3=0x2002AC76
    TARGET.CAPABILITY = ALL -TCB # Edit this for your needs, remember that dll cabas need to be equal or greater that the dll/lib it uses internally
    MMP_RULES += EXPORTUNFROZEN
    ...


    Hope this helps.

    -antti

  6. #6
    Registered User
    Join Date
    Nov 2009
    Posts
    26

    Re: Install 1.1.0 TP1 on symbian device

    Thanx for sharing this information
    i will try it.

  7. #7
    Regular Contributor
    Join Date
    Jul 2010
    Posts
    66

    Re: Install 1.1.0 TP1 on symbian device

    If you get it working on the device, please reply to this thread - and especially if you're doing any "magic" along the way, it would be interesting.

  8. #8
    Registered User
    Join Date
    Apr 2009
    Posts
    506

    Re: Install 1.1.0 TP1 on symbian device

    Hi

    It seems new SDK for S^3 contains all missed libs and headers, such as LBT etc
    Symbian & Qt developer. http://vladest.org

Similar Threads

  1. How to install on device
    By vbpatil.mail in forum Symbian
    Replies: 3
    Last Post: 2009-10-30, 07:28
  2. Install works on 3.12 firmware device, fails on 5.11 device
    By pbartkow in forum Near Field Communication
    Replies: 6
    Last Post: 2008-05-05, 19:21
  3. how to install the .sis file to symbian device?
    By niuweixing in forum Symbian Networking & Messaging (Closed)
    Replies: 1
    Last Post: 2007-09-03, 04:32
  4. Replies: 0
    Last Post: 2007-03-30, 11:18
  5. File transfer error through WinCE device to Symbian device
    By lal.rajan in forum Bluetooth Technology
    Replies: 0
    Last Post: 2007-03-30, 11:17

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •