×

Discussion Board

Page 1 of 2 12 LastLast
Results 1 to 15 of 17
  1. #1
    Registered User
    Join Date
    Jul 2010
    Posts
    98

    [Moved]unable install in the phone

    i have created the sis file using the phone debug mode . when installing the sis file in the mobile i am getting the error message "Unable to install"

  2. #2
    Nokia Developer Moderator
    Join Date
    Oct 2006
    Location
    Finland
    Posts
    4,563

    Re: unable install in the phone

    Quote Originally Posted by ragu. View Post
    i have created the sis file using the phone debug mode . when installing the sis file in the mobile i am getting the error message "Unable to install"
    Check http://developer.symbian.org/wiki/in...llation_Errors

    Will move your post to the correct place "Installation, Certification and Security"

  3. #3
    Registered User
    Join Date
    Jul 2010
    Posts
    98

    Re: unable install in the phone

    when i am rebuild the application i am getting the error connot open the file dialer.rsg ... .. this system generated file ....

  4. #4
    Nokia Developer Moderator
    Join Date
    Oct 2006
    Location
    Finland
    Posts
    4,563

    Re: unable install in the phone

    Quote Originally Posted by ragu. View Post
    when i am rebuild the application i am getting the error connot open the file dialer.rsg ... .. this system generated file ....
    You are having some error in the dialer.rss file. The resource build system generates the rsg and rsc files from them.

  5. #5
    Registered User
    Join Date
    Jul 2010
    Posts
    98

    Re: unable install in the phone

    Thank you

    i have cleared that error but now i am getting *cpp failed .. how to clear this error

  6. #6
    Nokia Developer Moderator
    Join Date
    Oct 2006
    Location
    Finland
    Posts
    4,563

    Re: unable install in the phone

    Check your mmp file for the cpp files listed and their relative paths. I am guessing that a certain cpp file listed there is not present in your file system(atleast not mentioned in the relative path)

  7. #7
    Registered User
    Join Date
    Jul 2010
    Posts
    98

    Re: unable install in the phone

    thanks .. now i can create the sis file .. when installing the file in the mobile phone i am getting the error unable to install or some times certificate error . this the pkg file i am using to create the sis file is there any problem .. ?


    ;Supports Series 60 v 3.0
    [0x101F7961], 0, 0, 0, {"Series60ProductID"}

    ;Files to install
    ;You should change the source paths to match that of your environment
    ;<source> <destination>
    "$(EPOCROOT)Epoc32\release\$(PLATFORM)\$(TARGET)\symbian_ua_gui.exe" -"!:\sys\bin\symbian_ua_gui.exe"
    "$(EPOCROOT)Epoc32\data\z\resource\apps\symbian_ua_gui.r01" -"!:\resource\apps\symbian_ua_gui.r01"
    "$(EPOCROOT)Epoc32\data\z\private\10003a3f\apps\symbian_ua_gui_reg.r01" -"!:\private\10003a3f\import\apps\symbian_ua_gui_reg.r01"
    "$(EPOCROOT)epoc32\data\z\resource\apps\symbian_ua_gui_aif.mif" -"!:\resource\apps\symbian_ua_gui_aif.mif"
    "$(EPOCROOT)epoc32\data\z\resource\apps\symbian_ua_gui.mbm" -"!:\resource\apps\symbian_ua_gui.mbm"
    ; Add any installation notes if applicable
    ;"symbian_ua_gui.txt" -"!:\private\0xEBD12EE4\symbian_ua_gui.txt"



    thanks in advance

  8. #8
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,171

    Re: unable install in the phone

    What are the excat errors shown ?
    And how did you handle the signing of the sis file ?

    Also do change the "!:\private\0xEBD12EE4\symbian_ua_gui.txt" to "!:\private\EBD12EE4\symbian_ua_gui.txt"

  9. #9
    Registered User
    Join Date
    Jul 2010
    Posts
    98

    Re: unable install in the phone

    When installing on the phone

    i am getting one of these error

    either

    1. Unable to install

    or

    2. certificate error contact the application supplier

  10. #10
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,171

    Re: unable install in the phone

    Did you try what I asked you to try ?, also please answer all questions asked from you, otherwise you are not providing enough information, so we wont be able to help you.

  11. #11
    Nokia Developer Moderator
    Join Date
    Oct 2006
    Location
    Finland
    Posts
    4,563

    Re: unable install in the phone

    Quote Originally Posted by ragu. View Post
    When installing on the phone

    i am getting one of these error

    either

    1. Unable to install

    or

    2. certificate error contact the application supplier
    Did you do what Jukka asked you for in post #8.

    Also did you even check the link in post#2? That has suggestions and checklist for all kinds of installation errors.

  12. #12
    Registered User
    Join Date
    Jul 2010
    Posts
    98

    Re: unable install in the phone

    yes . i did as yucca said in post #8 and

    Also do change the "!:\private\0xEBD12EE4\symbian_ua_gui.txt" to "!:\private\EBD12EE4\symbian_ua_gui.txt"

    i have changed this in the pkg file but still i am getting the same error ...


    i am using the develper OVI certificate for siging sis file

  13. #13
    Registered User
    Join Date
    Jul 2010
    Posts
    98

    Re: unable install in the phone

    i checked the link given in the post #2 .. This is the pkg file i am using to create the si file there is no 2 executables or it did not access any protected folder ....

    ; symbian_ua_gui.pkg
    ; This is an auto-generated PKG file by Carbide.
    ; This file uses variables specific to Carbide builds that will not work
    ; on command-line builds. If you want to use this generated PKG file from the
    ; command-line tools you will need to modify the variables with the appropriate
    ; values: $(EPOCROOT), $(PLATFORM), $(TARGET)
    ; Also, the resource file entries should be changed to match the language
    ; used in the build. For example, if building for LANGUAGE_01, change the file
    ; extensions .rsc to .r01.
    ;
    ;Language - standard language definitions
    &EN

    ; standard SIS file header
    #{"VoIPDialer"},(0xEBD12EE4),1,0,0

    ;Localised Vendor name
    %{"Vendor-EN"}

    ;Unique Vendor name
    :"Vendor"

    ;Supports Series 60 v 3.0
    [0x101F7961], 0, 0, 0, {"Series60ProductID"}

    ;Files to install
    ;You should change the source paths to match that of your environment
    ;<source> <destination>
    "$(EPOCROOT)Epoc32\release\$(PLATFORM)\$(TARGET)\symbian_ua_gui.exe" -"!:\sys\bin\symbian_ua_gui.exe"
    "$(EPOCROOT)Epoc32\data\z\resource\apps\symbian_ua_gui.r01" -"!:\resource\apps\symbian_ua_gui.r01"
    "$(EPOCROOT)Epoc32\data\z\private\10003a3f\apps\symbian_ua_gui_reg.r01" -"!:\private\10003a3f\import\apps\symbian_ua_gui_reg.r01"
    "$(EPOCROOT)epoc32\data\z\resource\apps\symbian_ua_gui_aif.mif" -"!:\resource\apps\symbian_ua_gui_aif.mif"
    "$(EPOCROOT)epoc32\data\z\resource\apps\symbian_ua_gui.mbm" -"!:\resource\apps\symbian_ua_gui.mbm"
    ; Add any installation notes if applicable
    ;"symbian_ua_gui.txt" -"!:\private\EBD12EE4\symbian_ua_gui.txt"

  14. #14
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,171

    Re: unable install in the phone

    for the capability issue, check what capabilities you are using, as well as you do have the device IMEI included in the certificate. Anyway, are you still getting the "unable to install error", and if you are when does it show that error ?

  15. #15
    Registered User
    Join Date
    Jul 2010
    Posts
    98

    Re: unable install in the phone

    Quote Originally Posted by symbianyucca View Post
    for the capability issue, check what capabilities you are using, as well as you do have the device IMEI included in the certificate. Anyway, are you still getting the "unable to install error", and if you are when does it show that error ?
    now i am not getting th0e error

    "unable to install "

    now i am getting the error

    "certificate error contact the application supplier"

    wat you suppoesed to this line
    "as well as you do have the device IMEI included in the certificate"

Similar Threads

  1. [Moved]Unable to install
    By chetanchauhan14 in forum Symbian Signed Support, Application Packaging and Distribution and Security
    Replies: 4
    Last Post: 2010-05-20, 19:21
  2. [Moved] "Unable to install. Component is built in." on N86 8mp nokia phone
    By chandran.biju007 in forum Symbian Signed Support, Application Packaging and Distribution and Security
    Replies: 3
    Last Post: 2010-03-22, 16:45
  3. [moved] UNABLE TO INSTALL
    By vishalrocks101 in forum Symbian Signed Support, Application Packaging and Distribution and Security
    Replies: 11
    Last Post: 2009-11-30, 16:31
  4. [moved] Unable to install
    By sonia1986 in forum Symbian Signed Support, Application Packaging and Distribution and Security
    Replies: 32
    Last Post: 2009-11-16, 10:53
  5. [moved] Unable to Install
    By Daaku in forum Symbian Signed Support, Application Packaging and Distribution and Security
    Replies: 18
    Last Post: 2009-08-20, 14:18

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×