×

Discussion Board

Results 1 to 4 of 4
  1. #1
    Registered User
    Join Date
    Jan 2009
    Posts
    25

    Issues using 5th ed SDK on old FP1 devices?

    Since the switch to the 5th ed SDK a few months back we have found a handful of FP1 devices that will no longer allow installation of the sis file (unable to install error). Mostly device released 3-4+ years ago. When we switch back to the FP1 SDK, it installs fine. The one device we see this on is the Nokia N93, N71, E61, and E70.

    is this a bug/problem or is it expected? should we be blocking the sis file from installing on FP1 devices while using the 5th ed SDK? in turn requiring us to release two builds (FP1 and then FP2/5th)?

  2. #2
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,748

    Re: Issues using 5th ed SDK on old FP1 devices?

    Backward compatibility means that new devices can run most code which is built for older devices. This thing exists.
    What you want would be forward compatibility, there is no such thing.

    Just an obvious example: have you noticed that N93, N71, E61 and E70 has no touchscreen, while all S60 5th edition devices have?
    In fact the S60 3rd FP1 SDK may be still too new for the N93 or the E61, since they are FP-less devices.
    If you want a single build, that should rather be S60 3rd MR. If you are using some special API-s, especially the ones from the various plug-in packs, it may happen that you will have to create separate builds for all S60 3rd and 5th edition variants.

  3. #3
    Registered User
    Join Date
    Jan 2009
    Posts
    25

    Re: Issues using 5th ed SDK on old FP1 devices?

    Thanks for the patronizing response. I understand what the difference is between 3rd and 5th and I understand forward/backward compatibility. I didn't ask WHY there was an issue installing on an old FP1 device.

    let me make my question more clear so it can be answered without and condescending remarks.

    Is it documented which FP1 devices are, or are not, compatible with the 5th ed SDK?

    E61 (FP1) will not allow install (unable to install error).
    N95 (FP1) allows install and the application works as expected.
    N79 (FP2) allows install and the application works as expected.
    N97 (5th) allows install and the application works as expected.

  4. #4
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,748

    Re: Issues using 5th ed SDK on old FP1 devices?

    Quote Originally Posted by serickson@fb-4.com View Post
    Thanks for the patronizing response.
    You are welcome.
    Is it documented which FP1 devices are, or are not, compatible with the 5th ed SDK?
    None of them are considered to be compatible.
    E61 (FP1) will not allow install (unable to install error).
    That is normal and expected. The E61 is still an FP-less device, as it has been mentioned already. http://www.forum.nokia.com/Devices/D...ifications/E61
    N95 (FP1) allows install and the application works as expected.
    N79 (FP2) allows install and the application works as expected.
    That is called luck.
    N97 (5th) allows install and the application works as expected.
    That is normal and expected.

Similar Threads

  1. S40 5th Ed FP1
    By Geethaarasu in forum Mobile Java Games
    Replies: 4
    Last Post: 2009-04-01, 19:39
  2. S40 5th Ed fp1(supernova models)
    By Geethaarasu in forum Mobile Java General
    Replies: 7
    Last Post: 2008-09-15, 06:39
  3. S40 5th Ed FP1
    By Geethaarasu in forum Mobile Java General
    Replies: 4
    Last Post: 2008-07-18, 11:31
  4. S40 5th Ed FP1
    By Geethaarasu in forum Symbian
    Replies: 1
    Last Post: 2008-07-16, 09:46

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×