×

Discussion Board

Results 1 to 6 of 6
  1. #1
    Registered User
    Join Date
    Jul 2010
    Posts
    13

    Unhappy big problem in lwuit

    i have sample program using lwuit . it is good in SUN JAVA WIRELESS TOOLKIT
    but icant be ran in sony erricson sdk (debug on device) i selected jp8 devices.
    my jdk version is 6 update 5.
    please help me.
    /////////////////////////
    show error is
    Error preverifying class com.sun.lwuit.animations.Transition3D
    VERIFIER ERROR com/sun/lwuit/animations/Transition3D.initTransition()V:
    Cannot find class javax/microedition/m3g/Node
    ///////////////////////////////
    my program is
    import com.sun.lwuit.*;
    import com.sun.lwuit.layouts.BorderLayout;

    public class HelloMidlet extends javax.microedition.midlet.MIDlet {

    public void startApp() {
    //init the LWUIT Display
    Display.init(this);

    // Setting the application theme is discussed
    // later in the theme chapter and the resources chapter

    Form f = new Form();
    f.setLayout(new BorderLayout());
    f.addComponent("Center", new Label("I am a Label"));
    f.show();
    }

    public void pauseApp() {
    }

    public void destroyApp(boolean unconditional) {
    }
    }

  2. #2
    Registered User
    Join Date
    Dec 2009
    Location
    chennai
    Posts
    137

    Re: big problem in lwuit

    i tested the LWUIT application in jp8. but i didnt face this type of issues. can u check it the version of LWUIT? are u using current version?

    and are u using transition in ur project? if u r using means u can check M3G.isM3GSupported()...
    Bharath... :)

  3. #3
    Registered User
    Join Date
    Jul 2010
    Posts
    13

    Re: big problem in lwuit

    hi
    i use lwuit 1.3 .
    should i copy lwuit jar file into some directory in sonyerricson sdk library?

  4. #4
    Registered User
    Join Date
    Dec 2009
    Location
    chennai
    Posts
    137

    Re: big problem in lwuit

    Quote Originally Posted by sadeghvaziri View Post
    hi
    i use lwuit 1.3 .
    should i copy lwuit jar file into some directory in sonyerricson sdk library?
    no need... see this link..
    http://forums.java.net/jive/thread.j...45752&tstart=0
    Bharath... :)

  5. #5
    Registered User
    Join Date
    Jul 2010
    Posts
    13

    Re: big problem in lwuit

    this link has not any solution.
    i have seen it before.

  6. #6
    Registered User
    Join Date
    Dec 2009
    Location
    chennai
    Posts
    137

    Re: big problem in lwuit

    are u using Transition3D? if u r using means u can check with M3G.isM3GSupported()...
    some emulators doesnt support m3g.. and LWUIT 1.4 was released. try to use latest lwuit and check it. and check the obfuscating level...
    Bharath... :)

Similar Threads

  1. Lwuit problem
    By ingsaurabh in forum Mobile Java General
    Replies: 17
    Last Post: 2011-04-20, 13:46
  2. problem in LWUIT
    By sadeghvaziri in forum Mobile Java General
    Replies: 3
    Last Post: 2010-08-20, 18:05
  3. OVI store billing one big fun, one big not working black bole
    By xlazom00 in forum [Closed] Publishing to Nokia Store
    Replies: 2
    Last Post: 2010-08-12, 20:16
  4. Problem using LWUIT
    By rachelwiz in forum Mobile Java General
    Replies: 5
    Last Post: 2010-04-09, 05:12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×