×

Discussion Board

Results 1 to 3 of 3
  1. #1
    Registered User
    Join Date
    Mar 2010
    Posts
    49

    Discussion/Questions on SW Install Launcher API

    Hello,

    I'm using the SW Install Launcher API to install applications on a E51 (actually I'm using the XQInstaller, which is just a wrapper around the Symbian API).

    I'm trying to install different packages in order to verify that the behavior is desired in all cases. Currently, I have faced two problems with following packages:

    1. fluidlauncher.sis
    Installation is silent. However, after first installation the phone displays an individual Icon for each demo application. When installing manually there is only one icon for the main entry. If I install the same application again with SW Installer API ("override"), extra icons disappear and result is same as with manual installation. Why?

    1.qt_installer.sis
    During the installation the installer asks for internet access (somehow related to the embedded files?). Is there any way to make it silent? I have tried pretty much all relevant SwiUI::TInstallOptions without visible results.

    Thanks for replies.

  2. #2
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,674

    Re: Discussion/Questions on SW Install Launcher API

    1) you may want to check the .pkg file. Self-dependent usage of "if exists" can result in deploying-removing a file on consecutive installations.
    2) if it is the so called "smart installer", it downloads the missing packages from the net (like Qt itself). S60 3rd FP1 devices (like the E51) have no concept for IAP precedences, default IAP, so there is no real workaround for selecting a single best IAP automatically. The behaviour may have changed in newer devices.

  3. #3
    Registered User
    Join Date
    Mar 2010
    Posts
    49

    Re: Discussion/Questions on SW Install Launcher API

    Quote Originally Posted by wizard_hu_ View Post
    1) you may want to check the .pkg file. Self-dependent usage of "if exists" can result in deploying-removing a file on consecutive installations.
    It was just the demo package distributed with the Nokia Qt SDK. So that seems to be flaw in the .pkg file.

    Quote Originally Posted by wizard_hu_ View Post
    2) if it is the so called "smart installer", it downloads the missing packages from the net (like Qt itself). S60 3rd FP1 devices (like the E51) have no concept for IAP precedences, default IAP, so there is no real workaround for selecting a single best IAP automatically. The behaviour may have changed in newer devices.
    It was the full qt installation package (>10Mb, qt_installer.sis) which also came with the SDK. As far as I know that package contains everything and does not download anything, at least when installing it manually. In addition, it seems that the installation isn't silent at all (notifies about installed dependencies etc). Basically the problem is: Is it possible to install that whole qt_installer.sis (e.g. upgrade) silently without any visible notifications for the user.

Similar Threads

  1. Replies: 2
    Last Post: 2010-06-23, 06:01
  2. Problem when SW Installer Launcher API
    By nguyend in forum Symbian
    Replies: 11
    Last Post: 2009-12-21, 14:30
  3. Decline installation using SW Installer Launcher API
    By _yarik_ in forum Symbian Signed Support, Application Packaging and Distribution and Security
    Replies: 1
    Last Post: 2009-05-13, 08:37
  4. Replies: 7
    Last Post: 2009-05-08, 17:17
  5. Replies: 4
    Last Post: 2008-02-12, 01:28

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×