×

Discussion Board

Results 1 to 10 of 10

Hybrid View

  1. #1
    Super Contributor
    Join Date
    Mar 2004
    Location
    Singapore
    Posts
    9,968

    Problem with Qt Mobility 1.1.0 TP For Symbian

    As you can see there are number of missing modules where can i find them, without these the corrsponding DLLs are not creatd.

    Code:
    Checking available Qt
    4.6.3
    Checking make
    ... Symbian abld make found.
    
    Start of compile tests
    Checking LBT
    ... Not Found
    Checking SNAP
    ... Not Found
    Checking OCC
    ... Not Found
    Checking SymbianContactSIM
    ... Not Found
    Checking SymbianContactModel
    ... OK
    Checking SymbianContactModelv2
    ... Not Found
    Checking S60_Sensor_API
    ... Not Found
    Checking Symbian_Sensor_Framework
    ... Not Found
    Checking Symbian_Hb
    ... Not Found
    Checking Audiorouting_s60
    ... Not Found
    Checking Tunerlibrary_for_3.1
    ... Not Found
    Checking RadioUtility_for_post_3.1
    ... Not Found
    Checking OpenMaxAl_support
    ... Not Found
    Checking Surfaces_s60
    ... Not Found
    Checking Symbian_Messaging_Freestyle
    ... Not Found
    Checking IMMERSION
    ... Not Found
    End of compile tests
    
    ...
    ...
    ...

  2. #2
    Nokia Developer Expert
    Join Date
    Dec 2009
    Posts
    81

    Re: Problem with Qt Mobility 1.1.0 TP For Symbian

    Those are the results of the compile tests, which are used to determine if optional functionality is present. For example, if LBT is present then the Symbian specific QGeoAreaMonitor backend will be used.

    I don't believe that any of th the compile tests need to pass in order to build Qt Mobility. Are there any other error messages occurring? Which DLLs are you creating / where are you looking for them?

  3. #3
    Super Contributor
    Join Date
    Mar 2004
    Location
    Singapore
    Posts
    9,968

    Re: Problem with Qt Mobility 1.1.0 TP For Symbian

    Thanks for the reply
    Quote Originally Posted by dalaing View Post
    Those are the results of the compile tests, which are used to determine if optional functionality is present. For example, if LBT is present then the Symbian specific QGeoAreaMonitor backend will be used.

    I don't believe that any of th the compile tests need to pass in order to build Qt Mobility.
    Yes it fails(just skips) to build corresponding dll files.
    Are there any other error messages occurring? Which DLLs are you creating / where are you looking for them?
    there where no Errors in building the dlls but packaging fails as the make did not build the correspding DLLs at-all.

  4. #4
    Nokia Developer Expert
    Join Date
    Dec 2009
    Posts
    81

    Re: Problem with Qt Mobility 1.1.0 TP For Symbian

    I don't think I'll be able to help much without quite a bit more information.

    Which DLL files are you talking about? What options are you passing to the configure line? What errors are you getting during packaging?

  5. #5
    Super Contributor
    Join Date
    Mar 2004
    Location
    Singapore
    Posts
    9,968

    Re: Problem with Qt Mobility 1.1.0 TP For Symbian

    1. when i try building the Qt Mobility from source i get the warning as shown in #1
    2. the dlls i am talking about are from the QtMobility_template.pkg qtcontacts_symbian.dll

  6. #6
    Nokia Developer Expert
    Join Date
    Dec 2009
    Posts
    81

    Re: Problem with Qt Mobility 1.1.0 TP For Symbian

    What steps are you going through to build mobility from source? Are you getting any more output than what is shown in #1? Because the output in #1 isn't a warning - if something is going wrong there's a very strong chance that it's being described by an error message which occurs somewhere after what you provided in #1.

Similar Threads

  1. Qt Creator code completion not working with Qt Mobility for Symbian
    By ceefour in forum [Archived] Qt Mobility Project
    Replies: 4
    Last Post: 2011-09-10, 05:02
  2. Qt Mobility for Symbian^3
    By eldergms in forum [Archived] Qt Mobility Project
    Replies: 0
    Last Post: 2010-06-30, 18:25
  3. problem with install qt mobility
    By huimei520 in forum [Archived] Qt Mobility Project
    Replies: 5
    Last Post: 2010-04-09, 04:52
  4. Problem with Qt Mobility
    By picachu.nioto in forum [Archived] Qt Mobility Project
    Replies: 7
    Last Post: 2010-04-06, 05:28
  5. Compiling Qt Mobility Problem
    By skumar_rao in forum [Archived] Qt Mobility Project
    Replies: 8
    Last Post: 2010-01-07, 00:13

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×