×

Discussion Board

Results 1 to 2 of 2
  1. #1
    Registered User
    Join Date
    Jun 2010
    Posts
    10

    Only recieving SMS signal on first run

    Hello,

    I'm having a problem with the Recieving and SMS in Qt example. Whenever I run the example for the first time in a while (reboot does not always seems to fix the problem), it works as it should. However, if I close the application and restart it, nothing happens when I recieve an SMS.

    Is there any reasonable explanation to this? The Qt Messaging initialization output is the same whenever it works and when it doesn't, and is posted below:

    Code:
    TpSession::onAMReady 
    
    TpSessionAccount::TpSessionAccount objectPath= "/org/freedesktop/Telepathy/Account/pecan/msn_2dpecan/******************" 
    TpSessionAccount::TpSessionAccount objectPath= "/org/freedesktop/Telepathy/Account/gabble/jabber/******************" 
    TpSessionAccount::TpSessionAccount objectPath= "/org/freedesktop/Telepathy/Account/ring/tel/ring" 
    TpSessionAccount::TpSessionAccount objectPath= "/org/freedesktop/Telepathy/Account/gabble/jabber/******************" 
    TpSessionAccount::TpSessionAccount objectPath= "/org/freedesktop/Telepathy/Account/gabble/jabber/******************" 
    TpSessionAccount::TpSessionAccount objectPath= "/org/freedesktop/Telepathy/Account/spirit/skype/******************" 
    TpSessionAccount::TpSessionAccount objectPath= "/org/freedesktop/Telepathy/Account/haze/msn/******************" 
    TpSessionAccount::TpSessionAccount objectPath= "/org/freedesktop/Telepathy/Account/haze/facebook/******************" 
    
    TpSessionAccount::TpSessionAccount objectPath= "/org/freedesktop/Telepathy/Account/butterfly/msn/******************" 
    
    TpSessionAccount::onReady cmName= "pecan" haveConnection= no 
    TpSession::onAccountReady:Account  "pecan" is Ready sync= true waiting: "ring" 
    TpSessionAccount::onReady cmName= "gabble" haveConnection= no 
    TpSession::onAccountReady:Account  "gabble" is Ready sync= true waiting: "ring" 
    Connecting to deprecated signal QDBusConnectionInterface::serviceOwnerChanged(QString,QString,QString)
    TpSessionAccount::onReady cmName= "ring" haveConnection= notReady 
    TpSessionAccount::onReady cmName= "gabble" haveConnection= no 
    TpSession::onAccountReady:Account  "gabble" is Ready sync= true waiting: "ring" 
    TpSessionAccount::onReady cmName= "gabble" haveConnection= no 
    TpSession::onAccountReady:Account  "gabble" is Ready sync= true waiting: "ring" 
    TpSessionAccount::onReady cmName= "spirit" haveConnection= no 
    TpSession::onAccountReady:Account  "spirit" is Ready sync= true waiting: "ring" 
    TpSessionAccount::onReady cmName= "haze" haveConnection= no 
    TpSession::onAccountReady:Account  "haze" is Ready sync= true waiting: "ring" 
    TpSessionAccount::onReady cmName= "haze" haveConnection= no 
    TpSession::onAccountReady:Account  "haze" is Ready sync= true waiting: "ring" 
    TpSessionAccount::onReady cmName= "butterfly" haveConnection= no 
    TpSession::onAccountReady:Account  "butterfly" is Ready sync= true waiting: "ring" 
    
    TpSessionAccount::onContactsConectionReady: connecting to Connection.Interface.NewChannels 
    
    TpSessionAccount::onContactsConnectionReady  "ring" 
    TpSession::onAccountReady:Account  "ring" is Ready sync= true waiting: "ring" 
    sync eventloop exit 
    ModestEngine::ModestEngine Starting to initialize 
    
    ModestEngine::ModestEngine Connecting to Modest DBus Interface 
    ModestEngine::ModestEngine Connected to Modest DBus Interface 
    ModestEngine::ModestEngine Connecting to Qt Mobility Modest Plugin DBus Interface 
    
    ModestEngine::ModestEngine Connected to Qt Mobility Modest Plugin DBus Interface 
    
    ModestEngine::ModestEngine Initialized successfully
    I'm running the code on an N900 with PR1.2 and libqtm-messaging 1:1.0.2-maemo1 installed. The application has been tested after either compiling in scratchbox (with the same libqtm-messaging version) or in MADDE using Nokia SDK 1.0 on Ubuntu.

    The problem is that the messageAdded function is not called when an SMS is recieved and the application is not running for the first time in a while.

    I'm guessing that there could be some DBUS listening which is not working, but I have no idea how to test this. Testing the application in Qt simulator does not work either, due to the following error output (which I presume is unrelated):

    Code:
    Messaging :  ( 24926 ) Failed to execute query; error:"attempt to write a readonly database Unable to fetch row"; statement:"INSERT INTO mailaccountconfig (id,service,name,value) VALUES (1,'qtopiamailfile','servicetype','storage')" 
    Failed to execute query; error:"attempt to write a readonly database Unable to fetch row"; statement:"INSERT INTO mailaccountconfig (id,service,name,value) VALUES (1,'qtopiamailfile','servicetype','storage')" 
    Messaging :  Could not execute query "updateAccount mailaccountconfig insert query" 
    Messaging :  24926 Unable to updateAccount - code: 8 
    Unable to add missing storage configuration for account: 1 
    Messaging :  Could not initialize content manager factory 
    Application running 
    Messaging :  ( 24914 ) Failed to execute query; error:"attempt to write a readonly database Unable to fetch row"; statement:"INSERT INTO mailaccountconfig (id,service,name,value) VALUES (1,'qtopiamailfile','servicetype','storage')" 
    Failed to execute query; error:"attempt to write a readonly database Unable to fetch row"; statement:"INSERT INTO mailaccountconfig (id,service,name,value) VALUES (1,'qtopiamailfile','servicetype','storage')" 
    Messaging :  Could not execute query "updateAccount mailaccountconfig insert query" 
    Messaging :  24914 Unable to updateAccount - code: 8 
    Unable to add missing storage configuration for account: 1 
    Messaging :  Could not initialize content manager factory 
    Unable to add folder for: "Inbox" 
    Unable to add folder for: "Outbox" 
    Unable to add folder for: "Drafts" 
    Unable to add folder for: "Sent" 
    Unable to add folder for: "Trash"
    I would be very grateful for any suggestions!

  2. #2
    Registered User
    Join Date
    Jun 2010
    Posts
    10

    Re: Only recieving SMS signal on first run

    After some more testing, there appears to be some progress if I close the conversation windows. I still don't get any output from the qDebug() calls in my messageAdded function, but I do get the following output when recieving messages after closing the conversation windows:

    Code:
    TpSessionAccount::onNewChannels 
     channelType: "org.freedesktop.Telepathy.Channel.Type.Text"  requested  : true  targetId "********" 
    
    TpSessionAccount::onNewChannels 
     channelType: "org.freedesktop.Telepathy.Channel.Type.Text"  requested  : false  targetId "********" 
    
    TpSessionAccount::onNewChannels path= path  "/org/freedesktop/Telepathy/Connection/ring/tel/ring/text9" 
    TpSessionChannel::TpSessionChannel path  "/org/freedesktop/Telepathy/Connection/ring/tel/ring/text9" 
    
    TpSessionChannel::onChannelReady type= "org.freedesktop.Telepathy.Channel.Type.Text" path  "/org/freedesktop/Telepathy/Connection/ring/tel/ring/text9" initiatorContact= "<SelfHandle>" 
    received  "" 
    TpSessionAccount::onMessageReceived  "" 
    TestProg::onMessageReceived  "" from  "********" 
    
    TpSessionAccount::onNewChannels 
     channelType: "org.freedesktop.Telepathy.Channel.Type.Text"  requested  : false  targetId "********" 
    TpSessionAccount::onNewChannels path= path  "/org/freedesktop/Telepathy/Connection/ring/tel/ring/text4" 
    
    TpSessionChannel::TpSessionChannel path  "/org/freedesktop/Telepathy/Connection/ring/tel/ring/text4" 
    
    TpSessionChannel::onChannelReady type= "org.freedesktop.Telepathy.Channel.Type.Text" path  "/org/freedesktop/Telepathy/Connection/ring/tel/ring/text4" initiatorContact= "********" 
    received  "testing" 
    TpSessionAccount::onMessageReceived  "testing" 
    TestProg::onMessageReceived  "testing" from  "********"
    The asterisks represent the sender's phone number.

Similar Threads

  1. SMS recieving PDU
    By sumit.rathi in forum Symbian
    Replies: 5
    Last Post: 2009-07-03, 07:16
  2. Recieving SMS over Bluetooth
    By MikeyBisbo in forum General Messaging
    Replies: 0
    Last Post: 2006-01-11, 09:19
  3. Recieving SMS with Java...
    By zeihor in forum Mobile Java General
    Replies: 2
    Last Post: 2004-11-14, 14:54
  4. Recieving SMS through PC from cellphone
    By mfarhanjamil in forum General Messaging
    Replies: 0
    Last Post: 2004-11-07, 06:15
  5. WMA: SMS recieving
    By 3hrguy in forum Mobile Java General
    Replies: 1
    Last Post: 2003-05-22, 09:18

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×