×

Discussion Board

Results 1 to 3 of 3
  1. #1
    Registered User
    Join Date
    Jun 2010
    Location
    CHENNAI
    Posts
    13

    Question Noise while playing RTP packets in E72

    Hi,


    we developed a VOIP application on symbian 3rd Edition FP2 using symbian c++ . Now we started testing the application in the device(E72). On the other end we are using X-lite on the system where Brekeke SIP server is installed.

    We are able to send and receive SIP requests and when we start RTP, RTP is transfered from Device to X-lite and vice versa. On X-lite ,when we play RTP packets ,it's very clear. But after receiving RTP packet from X-lite,when we send RTP packets to the E72 speaker(tried with handset mode also) noise is heard along with the actual voice. We added two bytes of data to the received packets and send it to the speaker and we are using PCMA codec both sides.

    Thanks in Advance..
    Last edited by krishnasrivatsa.n; 2010-10-14 at 07:54.

  2. #2
    Registered User
    Join Date
    Oct 2009
    Posts
    52

    Re: Noise while playing RTP packets in E72

    you can check the GAIN in your code and reduce it and use G711 codec

  3. #3
    Registered User
    Join Date
    Jun 2010
    Location
    CHENNAI
    Posts
    13

    Re: Noise while playing RTP packets in E72

    Thanks gamal,

    even though we changed gain, we still hearing the noise while playing the RTP packet. I think there is some problem while splitting the RTP packet and packet data conversions.

Similar Threads

  1. Noise while playing G711 RTP
    By iswarya.devi in forum Symbian Media (Closed)
    Replies: 3
    Last Post: 2009-12-22, 05:29
  2. Background noise RTP
    By neelimabtt in forum Symbian Media (Closed)
    Replies: 0
    Last Post: 2009-06-24, 11:17
  3. Playing RTP Packets use VAS
    By neelimabtt in forum Symbian Networking & Messaging (Closed)
    Replies: 0
    Last Post: 2009-06-03, 11:07
  4. Noise while playing G.711 Audio
    By gpalvia in forum Symbian Media (Closed)
    Replies: 5
    Last Post: 2008-10-30, 16:35
  5. Noise while playing mp3 file
    By csymbian in forum General Development Questions
    Replies: 1
    Last Post: 2004-05-19, 10:46

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×