×

Discussion Board

Results 1 to 12 of 12
  1. #1
    Regular Contributor
    Join Date
    Aug 2009
    Posts
    93

    Unhappy General OS-related error

    Hi all,
    i created a program that uses poppler library (properly compiled in symbian) and QtWebkit, if i use only poppler it works, and also if i use only webkit works too... But if i put them all together it compiles correctly but when the app is starting it returns me "General OS-related error". Any advice??
    tnx
    Max

  2. #2
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,699

    Re: General OS-related error

    Check if there is some panic in the background: http://wiki.forum.nokia.com/index.ph...ded_panic_code

  3. #3
    Regular Contributor
    Join Date
    Aug 2009
    Posts
    93

    Re: General OS-related error

    tnx for ur advice, i need to debug the application on a device... my device is 5800 Xpress Music... I tried to install ErrRd.sis but it returns me: "Application not compatible with the phone, Continue Anyway?" What does it mean?? I have to enable some flags in mode code to enable the panic mode?

  4. #4
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,699

    Re: General OS-related error

    That is just a warning. ErrRd.sis was built with specifying S60 3rd edition compatibility. But you can freely install it, it will not do any harm.
    If you are building your own one (with the batch file on that page for example), you can modify the Series60ProductID-line (or add a new one), and specify the S60 5th platform identifier: http://wiki.forum.nokia.com/index.ph...fication_codes

  5. #5
    Regular Contributor
    Join Date
    Aug 2009
    Posts
    93

    Re: General OS-related error

    ok, now i have the errrd in resources, but when i start my application, no popup appear... how can i enable it? and when i launch the app through qtcreator it gives me back General Os-related error. What can i do?

  6. #6
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,699

    Re: General OS-related error

    If you do not see the popup after installing that ErrRd stuff, there is no popup...

    You could try installing the application manually on the device, an installation problem might be interpreted this way by the QtCreator. (By the way, have you checked/asked this issue in the Qt boards? You can find them if you click back to "Development Platforms" above, Qt category is just below Symbian C++)

  7. #7
    Regular Contributor
    Join Date
    Aug 2009
    Posts
    93

    Re: General OS-related error

    ok, if i install the application manually, i can install it, but when i try to launch my application nothing happens, and in QtCreator when i click on "Run" it says me installation complete and when it try to launch the application it give me the General OS-related error. That's why i suppose there's a panic or something similar

  8. #8
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,699

    Re: General OS-related error

    Quote Originally Posted by marsiliano View Post
    ok, if i install the application manually, i can install it, but when i try to launch my application nothing happens.
    Actually this is the part when the popup is expected to appear. Is ErrRd still installed?

  9. #9
    Regular Contributor
    Join Date
    Aug 2009
    Posts
    93

    Re: General OS-related error

    yes ErrRd is still installed, but no popup appears... is there something else that should be activated? I one of my tries using only the library without QtNetwork, a popup appeared once so ErrRd is workin. But in my final version of the program no popup appears while i'm loading...

  10. #10
    Registered User
    Join Date
    May 2008
    Location
    Surat Thani
    Posts
    260

    Re: General OS-related error

    Quote Originally Posted by marsiliano View Post
    ok, if i install the application manually, i can install it, but when i try to launch my application nothing happens, and in QtCreator when i click on "Run" it says me installation complete and when it try to launch the application it give me the General OS-related error. That's why i suppose there's a panic or something similar
    The Qt Creator error message and the symptoms might also point to a DLL problem - the application importing functions from a DLL that doesn't exist in the device, or importing nonexisting functions from one that exists in the device. There's no system error message even with ErrRd installed in this case, the app just doesn't start.

    It's weird though that putting the two parts of the application together would create linking problems, if they work fine separately. I guess you're putting everything in one exe file? One thing to try might be compiling both of the projects together with as minimal changes as possible, I guess simply renaming one of the main functions to main2 would be enough. This will show at least if the problem is in the code that glues the different parts together.

    If you want to investigate the linking problem possibility further, you can dump imports of a binary with the command petran -dump i appname.exe. You could then compare imports of the binaries of separate parts to the imports of them put together. This is a bit of a long shot though.

  11. #11
    Regular Contributor
    Join Date
    Aug 2009
    Posts
    93

    Re: General OS-related error

    The DLL is created using Carbide++. I mix both Symbian c++ function and Qt function. Should be this the cause of my problem??
    Any suggestion is more than welcome.
    Tnx
    Max
    Last edited by marsiliano; 2010-09-09 at 17:24.

  12. #12
    Regular Contributor
    Join Date
    Aug 2009
    Posts
    93

    Re: General OS-related error

    I finally solved my problem porting all the qt code into Qt creator... Not so elegant solution but it works fine...

    Tnx to TongMuan and wizard_hu_ for the precious support....

Similar Threads

  1. Problem with ' General OS-related error'
    By toto42toto in forum Symbian Signed Support, Application Packaging and Distribution and Security
    Replies: 7
    Last Post: 2010-07-20, 15:33
  2. Carbide 2.00, Application TRK 3.09, Error: 0x20 Unspecified general OS-related error
    By hyuan in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 2
    Last Post: 2009-02-03, 20:26

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×