×

Discussion Board

Results 1 to 6 of 6
  1. #1
    Nokia Developer Expert
    Join Date
    Mar 2003
    Posts
    2

    Installing the SDK with Borland C++Builder

    This question was at least partly asked before but it didn't receive any reply. So, I also have problem when installing Borland C++ Builder mobile edition. I install all the modules (SDK, mobile plugin, C++ Builder). When I then start the Builder it cannot find the SDK - I get error: "No SDK detected. A valid SDK has to be installed". On installing phase SDK gets there just fine. It is installed, path and EPOCROOT are set to correct places but Builder just don't see that. If I check from Builder's Tools -> Mobile Options I can also see that path and EPOCROOT are on place but there's no installed SDK and I cannot even add SDK from here!?! What should be done to get Builder to notice the SDK?

  2. #2
    Registered User
    Join Date
    May 2003
    Posts
    1
    try running MobileEditionRegClean.exe from /Extras/RegCleanUtility in the zip file. I had the same problem and this worked on my machine.

  3. #3
    Registered User
    Join Date
    May 2003
    Location
    Germany
    Posts
    40
    Hello, I had the same problem. You must uninstall SDK first and do a new install. Then it will be found correctly!

    Much fun! Alwin

  4. #4
    Registered User
    Join Date
    May 2003
    Location
    Espoo, the center of the world
    Posts
    4
    I have the same problem. After trying reinstalling, repairing, installing in different order using regclean in the middle and so on, I found out that the 0.9 SDK was not actually installed. The installer promised to install SDK but it obviously didn't. I tried to install SDK alone, but the program said that the corresponding .msi-file is missing... Let's see if I can find it.

  5. #5
    Registered User
    Join Date
    Oct 2003
    Posts
    1
    Hi all, :-) its my first post here and i speak/write not so good english, so please forgive me. :-))

    Ok i only want to say thank you to @LanzlG his hint works pretty good!

    I have first instal the //Series_60_SDK_v0.9_for_Symbian_OS
    and then i have seen i can download the // Borland_v1_1_S60_Nokia_Edition

    so i think its better i instal this thing. :-)

    i uninstal the v0.9 and instal the v1_1_S60 evrything works fine and start also, but when i try to make a new mobile projekt it means the same saying "No SDK detected. A valid SDK has to be installed". :-)

    well, after some time i was very angry :-) and i cant fine any solution.

    now i have found on this board and i wat say thakns a lot :-)

    so this is the end of my little first post of full error :-))


    see you l8er allig8er


    ups sorry i forgot, i use Win 2000
    Last edited by qbc; 2003-10-31 at 06:26.

  6. #6
    Registered User
    Join Date
    Aug 2003
    Location
    Rio de Janeiro / Brazil
    Posts
    23
    ok, I'm having this "No SDK detected" problem too.

    I'm using Windows 98 and MobileEditionRegClean.exe requires Windows NT or greater. This SDK needs Win NT/200/XP?

    I tried to uninstall/install/repair this sdk a lot of times and nothing! Please post the OS that you are using to run the SDK.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •