×

Discussion Board

Results 1 to 5 of 5
  1. #1
    Registered User
    Join Date
    Feb 2010
    Posts
    17

    Nokia Smart Installer 0.24 and QtWebkit

    Hello everyone. I'm trying to deploy an application using the QtWebkit.

    -the application is built with the latest Nokia Qt SDK(updated to the day - Qt 4.7 etc.) and compiled with Qt += webkit.
    -the application is installed using the Nokia Smart Installer, on a Nokia N97 device without any errors but fails to start because QtWebkit is not installed on the phone.
    -the application runs fine if QtWebkit 4.6.3 is pre-installed on the device.

    I was wondering if Nokia Smart Installer does not install Qt Webkit anymore or is there something I need to do for this to happen.

    Thanks a lot,
    Andrei

  2. #2
    Registered User
    Join Date
    Apr 2009
    Posts
    506

    Re: Nokia Smart Installer 0.24 and QtWebkit

    Quote Originally Posted by andreig1978 View Post
    Hello everyone. I'm trying to deploy an application using the QtWebkit.

    -the application is built with the latest Nokia Qt SDK(updated to the day - Qt 4.7 etc.) and compiled with Qt += webkit.
    I'm pretty sure that there is still no update for Nokia Qt SDK to 4.7
    Symbian & Qt developer. http://vladest.org

  3. #3
    Registered User
    Join Date
    Feb 2010
    Posts
    17

    Re: Nokia Smart Installer 0.24 and QtWebkit

    I'm sorry. You are right. It is Qt 4.6.3, Qt Mobility 1.0.2. And should be Qt Webkit 4.6.3

  4. #4
    Registered User
    Join Date
    May 2009
    Posts
    9

    Re: Nokia Smart Installer 0.24 and QtWebkit

    Maybe try adding the following to your PRO file:

    default_deployment.pkg_prerules += pkg_depends_webkit

    I thought it was enabled by default, but I could be mistaken. See http://doc.qt.nokia.com/4.6/qmake-va...tml#deployment

  5. #5
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,355

    Re: Nokia Smart Installer 0.24 and QtWebkit

    You can always check to see if the generated _template.pkg file has a webkit dependency. That is what the smart installer needs in order to tell that the component is needed and look for it.
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

Similar Threads

  1. Application deployed with smart installer only starts once on Nokia 5800/X6
    By andreig1978 in forum [Archived] Nokia Smart Installer for Symbian
    Replies: 11
    Last Post: 2010-08-25, 15:15
  2. Smart installer causes reboot
    By danhicksbyron in forum [Archived] Nokia Smart Installer for Symbian
    Replies: 3
    Last Post: 2010-07-21, 19:49
  3. RDA and smart installer
    By Guilo19 in forum [Archived] Nokia Smart Installer for Symbian
    Replies: 1
    Last Post: 2010-06-18, 22:34
  4. Smart installer and signing
    By stegemann in forum [Archived] Nokia Smart Installer for Symbian
    Replies: 1
    Last Post: 2010-06-18, 22:21
  5. Is anyone working on the Smart Installer ?
    By NRBrown in forum [Archived] Nokia Smart Installer for Symbian
    Replies: 4
    Last Post: 2010-04-16, 08:57

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •