He'res the deal: developers typically work on the latest firmwares, users often have the oldest and most buggy ones. For this reason Ovi QA team tests the oldest firmwares.

Shouldn't RDA have some of the older firmwares as well? For example, 5800XM ver. 20.0.012 would do nicely As it stands right now, we have for example 8 N97s in RDA, but all of them have the latest 22.0.110 version. Or 8 5800XM, but all of them have either 51.0.006 or 50.0.005 with older 20.0.012 nad 21.0.* versions completely missing...