Discussion Board

Results 1 to 5 of 5
  1. #1
    Registered User
    Join Date
    Sep 2006
    Location
    Sarajevo, Bosnia and Herzegovina
    Posts
    166

    pys60 2.2.2 vs pys60 2.5 [extensions porting and similar questions]

    hello pythoners, i have been absent from s60 world for a long time and seems like there was not much activity related to python.
    It seems like 2.5 version is just raw edition, but it has own advantages such es touch support and sensor framework support.
    I want to know, is there way to make older extensions made for 2.2.2 compatible with 2.5
    maybe some sort of 'imp' modification or something like that?

    Best regards

    wook

  2. #2
    Super Contributor
    Join Date
    Oct 2007
    Location
    Deva, Romania
    Posts
    3,471

    Re: pys60 2.2.2 vs pys60 2.5 [extensions porting and similar questions]

    Hi,

    Well, maybe the info in the documentation will help:
    http://pys60.garage.maemo.org/doc/s60/node185.html

  3. #3
    Registered User
    Join Date
    Apr 2009
    Posts
    166

    Re: pys60 2.2.2 vs pys60 2.5 [extensions porting and similar questions]

    wook
    is it you ?
    hehe how small the world of internet can be :P

  4. #4
    Registered User
    Join Date
    Sep 2006
    Location
    Sarajevo, Bosnia and Herzegovina
    Posts
    166

    Re: pys60 2.2.2 vs pys60 2.5 [extensions porting and similar questions]

    Thank you Bogdan, i will check it, btw, i think that porting of imp from 2.2.2 to 2.5 and everything should be solved, right?


    AJ, ay,ay,ay,ay itz me, who else should it be?
    This is not world of internet, this is world of freakness.

    greetingz

    wook

  5. #5
    Registered User
    Join Date
    Sep 2006
    Location
    Sarajevo, Bosnia and Herzegovina
    Posts
    166

    Re: pys60 2.2.2 vs pys60 2.5 [extensions porting and similar questions]

    I didn't want to start new thread over this issue, but, i followed instructions in url Bogdan posted and, i am facing some issues with it.
    First porting of appswitch went fine, import and calls are fine....

    But, porting of appuifw2 have some troubles, well, i made every include and everything and compiled it with cuccess but in first on import i had troubles, so i extended caps, i was able to import it, but, on any call scriptshell crashed, so i asked Calvin to send me his patch, after i rebuilt it and everything, i had same issue as before........i realy don't know what is reason of crash on every call.....
    I have both (self signed and devcert signed) shells and both behaves same when i import this module....
    Should i extend python25.dll caps or what?

    *i use python 2.0.0 and nokia n97 mini

    best regards

    wook

    btw, happy new year in advance

Similar Threads

  1. Debugging PyS60 extensions
    By Turatzuro in forum Symbian
    Replies: 7
    Last Post: 2010-12-07, 01:38
  2. PyS60 2.0 extensions
    By angelo788 in forum Symbian
    Replies: 1
    Last Post: 2010-05-17, 15:29
  3. how to do C extensions for pyS60 ?
    By VDVsx in forum Symbian
    Replies: 1
    Last Post: 2009-06-24, 18:28
  4. PyS60 Talks #2 : PyS60 Extensions
    By croozeus in forum Symbian
    Replies: 14
    Last Post: 2008-09-15, 14:23
  5. Creating PyS60 extensions
    By phishboh in forum Symbian
    Replies: 8
    Last Post: 2008-02-21, 12:44

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×