×

Discussion Board

Results 1 to 3 of 3
  1. #1
    Registered User
    Join Date
    Mar 2003
    Posts
    18

    Ovi store does not accept my .deb package

    Hi,

    I try to publish an maemo application as debian packege. Application itself is made by python and pyQT. I have packaged it with Ubuntu tools as debian package. Debian package itself is OK, because I can transfer it into N900 and install it with dpkg and installed application can be run from icon. And it can be removed also, by dpkg.

    But when I try to publish this package to Ovi Store, I get this kind of error message

    -------------------------------
    There were some validation errors! Further details are by the fields.
    Content file name Unique name of the file for internal use, e.g. Global Weather N95 Scandinavia
    Maemo file
    Install file for Maemo content type.
    Max file size: 350Mb
    File name: 3-100 alphanumerical characters
    File format: .deb
    Alert: File format: .deb
    --------------------------

    So as red is "Alert: File format: .deb"


    What can be wrong with it, because technically package is OK as I explained above? Is there some magic number checking that package is done in Maemo, not in Ubuntu, even if debian package done by Ubuntu works, when installing by hand?

    What does package size limit "350Mb" mean, is it bits or bytes? My package size is 4.2 MB (Mega Bytes).
    If i run "file package.deb", I get in Ubuntu
    ---------------------------
    Debian binary package (format 2.0)

    Solved:
    It was package naming limitation, explained here <http://discussion.forum.nokia.com/forum/showthread.php?207721-Unable-to-upload-Maemo-package-(.deb)-file-to-Ovi-Store>. I must rename package, so no "." are allowed in package name for version and packaging number must be removed, something like "my_package_0_1_0.deb", for package version 0.1.0-2.
    Last edited by korhore; 2010-10-13 at 23:47. Reason: Solved

  2. #2
    Nokia Developer Moderator
    Join Date
    Oct 2009
    Location
    Finland
    Posts
    327

    Re: Ovi store does not accept my .deb package

    Note that PyQt is a community-supported library and thus unfortunately not supported by the Ovi Store.

  3. #3
    Registered User
    Join Date
    Mar 2003
    Posts
    18

    Re: Ovi store does not accept my .deb package

    Quote Originally Posted by achipa View Post
    Note that PyQt is a community-supported library and thus unfortunately not supported by the Ovi Store.
    Meaning, that we can't publish application in Ovi Store using PyQt?

    What about pyside? It was Nokia-supported?

Similar Threads

  1. Where to upload Maemo Package (.deb)?
    By lukiluuk in forum [Closed] Publishing to Nokia Store
    Replies: 3
    Last Post: 2010-09-10, 22:17
  2. Replies: 4
    Last Post: 2010-08-30, 07:33
  3. Qt Creator deb package
    By atonical in forum Nokia N9
    Replies: 16
    Last Post: 2010-07-05, 10:03
  4. Windows Mobile app store competition to Ovi opens, where is Ovi store now
    By jimgilmour1 in forum [Closed] Publishing to Nokia Store
    Replies: 2
    Last Post: 2009-05-06, 16:36

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •