×

Discussion Board

Results 1 to 12 of 12
  1. #1
    Registered User
    Join Date
    Apr 2010
    Posts
    44

    Unhappy [moved] Cert stopped working

    Wha'ts wrong now. I installed the 3rd pack at the side of 5th one to carbide.
    Also had mine cert & key +.sis files from the nokia beta program. Did make couple of apps and they are published and working fine in the Ovi.

    My latest app how ever did not work. Cannot install the .sisx even to my own device (that has the developer packet installed) and the previous "signed" .sisx worked fine. Now it says Cert expired.

    My idea is that the /sis/myapp.pkg has invalid vendor names.
    Do I need to change the .pkg file and what to type in there? is it company Ltd, Company LTD or what..?
    Previous apps worked fine without any modification of this file..


    http://blogs.forum.nokia.com/blog/ov.../qt-content-qa

  2. #2
    Nokia Developer Champion
    Join Date
    Mar 2006
    Location
    Helsinki, Finland
    Posts
    8,345

    Re: [moved] Cert stopped working

    Since your query is more related to Ovi publishing, I am moving your thread here.

    You need to send an email to Ovi publish team and they may help you. But before sending an email, please read this similar discussion on this thread: http://discussion.forum.nokia.com/fo...a-shared-UID-s
    Nokia Developer Wiki Moderation team

  3. #3
    Registered User
    Join Date
    Apr 2010
    Posts
    44

    Re: [moved] Cert stopped working

    I tested this with another pc also. Same problem.
    First I got the cert + 2 uids. Later I got more uids and have been using one of them with success.
    How ever something happened now and the signing does not work anymore. Could it be something to do with s603rd extension also installed in the same pc ?

  4. #4
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,166

    Re: [moved] Cert stopped working

    Basically, check that you are signing only unsigned sis files, some older devices did only check the most upper one, but newer devices are checking them all, and if any of the certificate is not valid it gices errors for it. Also you could use signsis to check the sis files certificates and the validity peiod for all signatures in it.

    Also do cehck that your time settings are ok in all devices, and propably you could see that your pc has correct date & time as well. And then I'm not certain on what is the "developer packet", and what is has to do with certificate issues.

  5. #5
    Super Contributor
    Join Date
    Jul 2008
    Posts
    2,020

    Re: [moved] Cert stopped working

    Quote Originally Posted by symbianyucca View Post

    Also do cehck that your time settings are ok in all devices, and propably you could see that your pc has correct date & time as well. And then I'm not certain on what is the "developer packet", and what is has to do with certificate issues.
    My friend, the walking, talking Yucca tree, has the problem nailed. AFAIK (my wife handles that in our office), there has been a DST change recently.

    Check if: a) Your PC is set to the correct location(!!!), time and date(!!)
    b) Check iof your phone is set to the same data, but the time two minutes ahead

    Does that fix your issue?
    The lines above are the best I have to offer.If anyone of you is of more advanced knowledge, I ask for your patience and understanding! - unknown arab poet
    http://www.tamoggemon.com - Symbian blog - Windows Phone blog
    My other blogs:
    webOS blog iPhone blog BlackBerry blog Samsung bada blog Android blog

  6. #6
    Registered User
    Join Date
    Apr 2010
    Posts
    44

    Re: [moved] Cert stopped working

    Thank you for your help!

    The developer sis in the phone was update to certs so that my phone accepts the signed .sisx file to be installed. It stopped working.
    I did change my date on the phone couple of times, but chaged it back. Already noticed earlier that if the phone's time is one minute earlier than pc, I have to wait before installing.

    I don't understand how to check location of pc/mobile ?
    Could there be a risen issue that my win XP is english, but phone is finnish. (Hate to use finnish os and programs, but it's nice to be able to type finnish letters like ö and ä )

    I'm signing the sis like before when they worked. Using carbide Gui and inserting .key .crt into project's settings..

    My pc was slow anyway so now I'm formatting the drive and installing all over again.. tomorrow we'll see that does this help..

  7. #7
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,166

    Re: [moved] Cert stopped working

    the different languages wont matter, I'm only using semi-english laptops (Thai-English, Finnish-English, and currently, partially German-fin-English) with english menu's on, and devices with multiple different language's on them, and never got any problems with it.

    the issue is solely on the certificate, and reinstallations most likely would make no difference. Anyway what was the "developer packet" you talked about ?, and did you check and do what was asked since your last post ?

  8. #8
    Registered User
    Join Date
    Apr 2010
    Posts
    44

    Re: [moved] Cert stopped working

    The "developer packet" was .sis file that Nokia sent when I got my cert. I strongly believe that it enables my phone to install my signed apps. (the .sisx) And it did it before successfully.
    Now I installed whole system again, checked versions of Perl etc. and made totally new flash stub c++ project. No errors while building. Also checked the dates & timezone.

    When trying to install the "signed carbide c++ made flash stub example" .sisx file in my phone it says "cert no longer valid".
    At this point it does NOT help if I adjust the phone's date + - 1 day or -2 months.

    ---
    The problem installing my phone could be that the "developer packet" in my phone does not contain the new uids. BUT this does not explain why my app got approved to OVI and failed to install on customer's phones with the same reason.
    I can make .sisx with the "random" uid, 0xe... but that wont help me to get the content into Ovi!

  9. #9
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,166

    Re: [moved] Cert stopped working

    if there is something magic on the sis you need to install to the device, then contact the publicer email to ask for assistance. Actually I'm not official Ovi support, thus would not know what that sis could contain.

    anyway, maybe you could try using the signsis to read the certificate(s) in your sis file to see the validity peiod it is having.

  10. #10
    Registered User
    Join Date
    Apr 2010
    Posts
    44

    Re: [moved] Cert stopped working

    Thank you Jukka for your help. I had emailed ovi support and got new certificate & key files today. After building the same app with them it worked.
    The phone developer packet's real name is "developer certificate installer" also got new one of those.

    So the conclusion: My cert was expired or it did not support the new range of uids.


    Current & fixed:

    Primary:
    Issued by : OVI Publisher 09-30-2010
    Issued to : OVI Publisher 09-30-2010
    Valid from 01/10/2010 to 30/12/2010

    Old that did not work:
    Primary:
    Issued by : OVI Publisher 06-28-2010.
    Issued to : OVI Publisher 06-28-2010.
    Valid from 28/06/2010 to 26/09/2010

    If I had just to know that there is tool signsis.exe mysis.sisx -o I havent wasted so much time to try fix the unfixable

  11. #11
    Super Contributor
    Join Date
    Jul 2008
    Posts
    2,020

    Re: [moved] Cert stopped working

    Quote Originally Posted by symbianyucca View Post
    the different languages wont matter, I'm only using semi-english laptops (Thai-English, Finnish-English, and currently, partially German-fin-English) with english menu's on, and devices with multiple different language's on them, and never got any problems with it.

    the issue is solely on the certificate, and reinstallations most likely would make no difference. Anyway what was the "developer packet" you talked about ?, and did you check and do what was asked since your last post ?
    Time Zone, I meant.

    Sorry for having expressed myself unclearly!
    The lines above are the best I have to offer.If anyone of you is of more advanced knowledge, I ask for your patience and understanding! - unknown arab poet
    http://www.tamoggemon.com - Symbian blog - Windows Phone blog
    My other blogs:
    webOS blog iPhone blog BlackBerry blog Samsung bada blog Android blog

  12. #12
    Regular Contributor
    Join Date
    Apr 2008
    Posts
    445

    Re: [moved] Cert stopped working

    Quote Originally Posted by juhauta View Post
    Thank you Jukka for your help. I had emailed ovi support and got new certificate & key files today. After building the same app with them it worked.
    The phone developer packet's real name is "developer certificate installer" also got new one of those.

    So the conclusion: My cert was expired or it did not support the new range of uids.


    Current & fixed:

    Primary:
    Issued by : OVI Publisher 09-30-2010
    Issued to : OVI Publisher 09-30-2010
    Valid from 01/10/2010 to 30/12/2010

    Old that did not work:
    Primary:
    Issued by : OVI Publisher 06-28-2010.
    Issued to : OVI Publisher 06-28-2010.
    Valid from 28/06/2010 to 26/09/2010

    If I had just to know that there is tool signsis.exe mysis.sisx -o I havent wasted so much time to try fix the unfixable
    Why are these free certificate's expiration deadlines that short/strict? The certificate works only on 1-5 devices, so the possibility of fraudulent use is almost zero.

Similar Threads

  1. N-Gage stopped working?
    By arlab in forum Streaming and Video
    Replies: 1
    Last Post: 2010-02-08, 06:26
  2. carbide.c++ 2.0 just stopped working
    By kolijoco in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 6
    Last Post: 2009-10-10, 22:24
  3. Application stopped working
    By vdharankar in forum Symbian Networking & Messaging (Closed)
    Replies: 1
    Last Post: 2009-08-25, 20:09
  4. Self signed stopped working
    By ganenko in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 17
    Last Post: 2009-07-28, 09:31

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×