×

Discussion Board

Results 1 to 5 of 5
  1. #1
    Registered User
    Join Date
    Aug 2006
    Posts
    46

    Cant see strings

    Hi.
    I have some weird problem and im sure it has very simple solution i just cant grasp it for some reason.
    I moved on from Winxp to Windows 7 x64 OS.
    And now when im running my old project on emulator it does not show strings, it shows empty rectangles instead.
    I believe it has something to do with LANGUAGE settings but i cant figure what i have to do to turn back.
    Please advise.
    Im using S60_3rd sdk along with Code Warrior 3.1.

  2. #2
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,674

    Re: Cant see strings

    It may matter if those strings are simple ASCII or some "real" Unicode stuff (like Chinese/Japanese/Thai, these are the ones having a language switcher shortcut in the program group of the SDK).
    Note that you are using very old tools, unless you have specific requirements upgrading the SDK to S60 3rd MR (which is the same platform revision, just with bugfixes) may be a good idea.

  3. #3
    Registered User
    Join Date
    Aug 2006
    Posts
    46

    Re: Cant see strings

    Ive tried it.
    somebody on other forum suggested to run this command
    C:\Symbian\9.1\S60_3rd_MR\Epoc32\tools\ecmt>javaw -classpath unzip.jar;plugins/general.jar;lib/log4j-1.2.8.jar -Dsource=language -Ddestination=..\..\.. -Dlanguage=en_us -Dplatform=winscw com.nokia.epdt.zip.ZipManager
    which is basically does the same.
    But no success, still my app is filled with rectangles.
    Any other suggestions?

  4. #4
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,674

    Re: Cant see strings

    What about the other applications in the emulator? Is it a GUI or a console based one? Are you trying to use a custom font? Are the strings of Latin characters?

  5. #5
    Registered User
    Join Date
    Aug 2006
    Posts
    46

    Re: Cant see strings

    Thanks for tip.
    Other applications looked ok.
    I also tried to remove localizations from my app, living only LANG 01 in mpp file.Application works with English ok, but when ive tried to put localizations back i got rectangles again.
    I can work with it but its very not comfortable, may be you have some ideas why its happening?

Similar Threads

  1. Strings
    By andy_watson00 in forum Symbian
    Replies: 6
    Last Post: 2009-06-02, 14:33
  2. Subracting Strings
    By richie.rich in forum Symbian
    Replies: 1
    Last Post: 2007-11-24, 14:01
  3. TInt like strings
    By gemilib in forum Symbian
    Replies: 4
    Last Post: 2007-11-06, 15:22
  4. strings?
    By praktikant in forum Symbian
    Replies: 4
    Last Post: 2007-07-13, 09:28
  5. Need AT Initiliasation Strings
    By geezerjohn in forum Multimodecards
    Replies: 0
    Last Post: 2003-10-15, 20:05

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×