×

Discussion Board

Results 1 to 6 of 6
  1. #1
    Registered User
    Join Date
    Sep 2010
    Posts
    17

    crash the emulator before the main has been called

    hello everyone,

    i use Carbide 2.6.0

    i got the problem when i try to start the app in the emulator (run as...). the emulator is disappear from the runnging.
    another try: i started again (debug as...): i have receive following info. in the console:

    Code:
        13.565    Thread akncapserver::OOM FW created @ 0xdfaf14 - Win32 Thread ID 0x1348
        13.570    xxxx KUikOOMWatchdogStatus err=0
        13.570    OOM WATCHER: Free RAM now:63471616
        13.570    Thread TestSuite.exe::Main created @ 0xe08d9c - Win32 Thread ID 0x1f68
        13.580    Thread TestSuite.exe::Local-00e0844c created @ 0xe08704 - Win32 Thread ID 0x1d04
        13.600    FAULT: nkern.cpp 00000574
    can somebody help me :(
    thx a lot

    best regards
    ~Ming

  2. #2
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,169

    Re: crash the emulator before the main has been called

    Can you check what the epocwind.out says in it.

  3. #3
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,751

    Re: crash the emulator before the main has been called

    Is it TestSuite.exe ?

  4. #4
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359

    Re: crash the emulator before the main has been called

    Gosh how I hate that default setting of Carbide's run profile.

    Please read this then see if switching the run profile to start epoc.exe gets you to a state where you can actually collect some useful info from the emulator.
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

  5. #5
    Registered User
    Join Date
    Sep 2010
    Posts
    17

    Re: crash the emulator before the main has been called

    after couple experiment i reinstalled the sdk :( it works again :D. maybe i deleted uncarefully some import files in epoc32/ folder.

    thanks for your reply!

    best regards
    ~Ming

  6. #6
    Registered User
    Join Date
    Sep 2010
    Posts
    17

    Re: crash the emulator before the main has been called

    Quote Originally Posted by wizard_hu_ View Post
    Is it TestSuite.exe ?
    i try to make some unittest for my app and i cannot found any unittest framework for symbian open c/c++. so wrote i it "unittest-like". maybe you know some unittest framework for symbian? like cppunit or boost::unitest?

    best regards
    ~Ming

Similar Threads

  1. Main thread gets called too late,why?
    By leejx in forum Symbian
    Replies: 7
    Last Post: 2009-10-20, 12:03
  2. Replies: 0
    Last Post: 2003-04-13, 23:59
  3. Main icon and the emulator
    By Jeepy in forum Symbian Tools & SDKs
    Replies: 3
    Last Post: 2002-12-11, 00:29
  4. Problem with the main menu in the emulator
    By roby1 in forum Bluetooth Technology
    Replies: 0
    Last Post: 2002-10-18, 11:50
  5. pauseApp() ever called on emulator?
    By Moruk79 in forum Mobile Java General
    Replies: 6
    Last Post: 1970-01-01, 02:00

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×