×

Discussion Board

Results 1 to 14 of 14

Hybrid View

  1. #1
    Registered User
    Join Date
    Sep 2010
    Posts
    14

    Api Bridge error

    Hello
    I'm having a problem using the API Bridge.
    I've installed the api on the phone, but I can not run any of the examples that come to class for flash lite. Everyone I show an error, eg: "Error while retrieving occured values".

    I need a help, because it is working for college.
    Thank you and sorry for the english @ google

  2. #2
    Nokia Developer Moderator
    Join Date
    May 2007
    Location
    Finland
    Posts
    134

    Re: Api Bridge error

    Can you send me a private message with your email, so I can get you in contact with your local Forum Nokia support, in your own language, hopefully

  3. #3
    Registered User
    Join Date
    Sep 2010
    Posts
    14

    Re: Api Bridge error

    Tnks.

    but you have any solution?? My phone is nokia e63

  4. #4
    Registered User
    Join Date
    Sep 2010
    Posts
    14

    Re: Api Bridge error

    I think the problem is in the installation of Api Bridg in my phone.
    Have any way of knowing if it was installed correctly?

    Sorry for multiple msg, but is very urgent!

  5. #5
    Registered User
    Join Date
    Sep 2010
    Posts
    14

    Re: Api Bridge error

    How should I install the Api Bridge in my mobile?

  6. #6
    Nokia Developer Moderator
    Join Date
    May 2007
    Location
    Finland
    Posts
    134

  7. #7
    Registered User
    Join Date
    Sep 2010
    Posts
    14

    Re: Api Bridge error

    I cannot test the examples of flash lite installing the api bridge normally?
    and then run the swf directly from my phone?
    Have a correct folder to put these files(swf)?

  8. #8
    Nokia Developer Champion
    Join Date
    Jul 2008
    Location
    Pakistan
    Posts
    1,065

    Re: Api Bridge error

    Hi cocamm,
    According to documentation of API Bridge,
    The APIBridge component is compatible with Nokia devices based on Symbian OS, S60 3.1 or later.
    As e63 is S60 3.1 it has to work with API Bridge, are u already try these samples :
    APIBridge_FlashLiteCode.zip
    Moreover, i request you to remove the API Bridge from your phone first, reinstall it to phone memory and restart your phone before using any of the samples & please, try all samples because may be few of the services are not available at ur phone.

    Best Regards,
    SajiSoft

  9. #9
    Registered User
    Join Date
    Sep 2010
    Posts
    14

    Re: Api Bridge error

    I did what you said and still did not work.

    The following message appeared in almost everything examples:
    "Error while retrieving ocurred values."

    Unfortunately I do not know what to do!! The delivery of the work is scheduled for December =(

  10. #10
    Nokia Developer Champion
    Join Date
    Jul 2008
    Location
    Pakistan
    Posts
    1,065

    Re: Api Bridge error

    Hi cocamm,
    What sort of features are you are looking for (in API Bridge)? You can go for Kuneri Lite as an alternative :
    http://www.kunerilite.net/
    or if u have good knowledge of Symbian C++, you can create your own local server and if u want take an easy route as this is a college project, you can use Python and Flash Lite. Take a look at this project :
    Flyer

    Best Regards,
    SajiSoft

  11. #11
    Registered User
    Join Date
    Sep 2010
    Posts
    14

    Re: Api Bridge error

    Tnks for reply.

    I'll try Kuneri Lite today and give you a feedback!!
    Tnks

  12. #12
    Registered User
    Join Date
    Sep 2010
    Posts
    14

    Re: Api Bridge error

    Also without success.

    To use the plugins with Kuneri like camera and download / upload, a certificate is required and I could not get it.

    And the examples, give invalid certificates on my phone.

    Why Api Bridge does not work here? I tried to install it in different ways and nothing.

  13. #13
    Registered User
    Join Date
    Sep 2010
    Posts
    14

    Re: Api Bridge error

    I have good news...

    The file APIBridgeTest.wgz works fine. Photos, video, upload......everything ok.

    But the swf examples still show me error.

  14. #14
    Nokia Developer Champion
    Join Date
    Feb 2005
    Location
    Karachi, Pakistan
    Posts
    277

    Re: Api Bridge error

    Another alternate is SWF + PyS60. PyS60 gives a lot more APIs to Flash than any other solution.

    You can then make an one simple SIS of your application using SWF2Go, and you can even include the PyS60 runtime in same SIS, so the end-user don't even have to look for it separately.

    Best,

    // chall3ng3r //
    Faisal Iqbal (skype: chall3ng3r)
    Flash Mobile Specialist | Orison Technologies
    _____________________________________
    blog: F·L·A·S·H·I·S·M
    swf2go: www.swf2go.com

Similar Threads

  1. API Bridge WRT
    By remy_david in forum Symbian
    Replies: 1
    Last Post: 2011-03-31, 19:56
  2. API bridge support for symbian^3
    By remy_david in forum Symbian
    Replies: 1
    Last Post: 2010-09-28, 08:24
  3. Using api bridge for custom ViewFinder
    By Christophe.A in forum Symbian Media (Closed)
    Replies: 3
    Last Post: 2010-04-14, 12:23
  4. How to use API bridge using symbian C++
    By sumit.ece in forum Symbian
    Replies: 3
    Last Post: 2010-03-22, 14:10
  5. How to use API bridge
    By sumit.ece in forum Symbian
    Replies: 2
    Last Post: 2010-03-22, 13:45

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •