×

Discussion Board

Results 1 to 4 of 4
  1. #1
    Registered User
    Join Date
    Sep 2010
    Posts
    17

    connect with localhost or 127.0.0.1 failed

    Hello everybody,

    envoriment:
    carbide 2.3
    s60_3rd_MR

    language:
    open c/c++ 1.7

    i am facing right now a strange problem:

    i built a small embed http server for my handy. in the application will the port 8089 and index query is opened for the access.

    2 tests:

    first one:
    i connected the handy with a acess point and the handy has the ip 192.168.2.10 and i opened the internet browers on my pc and tipped http://192.168.21.10:8089/query and i can see the website from handy.

    secnod one:
    now i want use the browser from handy to open the website. i tipped http://localhost:8089/query and http://127.0.0.1:8089/query and i became "Web Connection-timeout" error...

    and i tried to debug the error in carbide. my code has been called and used for the request from browser.

    can somebody tell or suggest me, how can i connect with localhost from handy? thanks very much for your help!

    best regards
    ~Ming
    Last edited by miluit01; 2010-11-12 at 14:09.

  2. #2
    Regular Contributor
    Join Date
    Aug 2010
    Posts
    347

    Re: connect with localhost or 127.0.0.1 failed

    I am facing a similar issue wrt SIP and have posted to this forum, but the response did not help resolve the issue. I am still debugging. Here is the link to my post:

    http://discussion.forum.nokia.com/fo...535#post793535

    HTH
    Vin

  3. #3
    Registered User
    Join Date
    Sep 2010
    Posts
    17

    Re: connect with localhost or 127.0.0.1 failed

    I am facing a similar issue wrt SIP and have posted to this forum, but the response did not help resolve the issue. I am still debugging. Here is the link to my post:

    http://discussion.forum.nokia.com/fo...535#post793535

    HTH
    Vin
    do you find something during debugging?

    i can see by my code(c/c++):

    the request from browser has been accepted from my application but the request repeat itself 4-5 times and then jump the error message in browser up.

    i used the embedd http server mongoose(c/c++). in the callback function for http request will be opend 4-5 isolate threads to response the requese.

    best regards
    ~Ming

  4. #4
    Regular Contributor
    Join Date
    Aug 2010
    Posts
    347

    Re: connect with localhost or 127.0.0.1 failed

    In my case, I see that the request is sent out on the local domain to the server. But the server does not recieve it and I do not get any response. I use TDIMon to sniff TCP packets.

Similar Threads

  1. connect emulator S60 to localhost 127.0.0.1
    By hariyanto_toto in forum Symbian Networking & Messaging (Closed)
    Replies: 2
    Last Post: 2010-10-10, 21:46
  2. connect emulator with 127.0.0.1
    By exoersist in forum Symbian Networking & Messaging (Closed)
    Replies: 3
    Last Post: 2008-02-18, 03:29
  3. How to connect to 127.0.0.1 with the browser?
    By Thin Myrna in forum Symbian
    Replies: 1
    Last Post: 2007-03-26, 17:29
  4. how to connect 127.0.0.1 or localhost
    By rkt_mkp123 in forum Wired and Wireless interfaces (Closed)
    Replies: 0
    Last Post: 2006-09-07, 09:08
  5. socket connection to localhost failed
    By xzhang36 in forum Symbian Networking & Messaging (Closed)
    Replies: 0
    Last Post: 2003-12-06, 06:47

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×