×

Discussion Board

Results 1 to 3 of 3
  1. #1
    Registered User
    Join Date
    Jul 2010
    Posts
    5

    Mapviewer from Mobility 1.1.0 requires QtMobility 1.0.2(0) during installation?

    I'm trying to install mapviewer example from Mobility 1.1.0. I'm able to compile it, but during installation to phone I get error, that QtMobility 1.02(0) is required. It probably means that QtMobility is 1.2 is required.

    On phone I have qt.sis from Qt 4.7.1 installed and also qt-mobility-symbian-1.1.0-s60.sis installed. I'm installing to 5230 (S60v5) with latest firmware.

    I get same error during installation for sysinfo example, but I was able to install modified quickstart example.

    I'm unable to compile mapviewer win7 target as it fails with linkage errors (I compiled libs from sources with mingw32). Compiling Symbian target gets 606 warnings.

    I have Win7 64bit, NokiaQtSDK 1.0.1, Qt 4.7.1, Mobility 1.1.0. It could be related that I have also tried to compile latest Mobility source from git repo for mingw32 (I didn't figure out how to compile repo source for symbian), but I'm not using it to my knowledge.

    I got mapviewer installed with mobility 1.1.0 beta2 and it started, but crashed when it tried to load maps (symbian). With mobility 1.1.0 beta2 I was able to run win7 target after I figured where to copy location plugins.

    Environment (in Qt Creator)
    PATH
    C:\NokiaQtSDK\mingw\bin;C:\Qt\4.7.1-symbian\bin;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\;C:\Qt\4.7.1-symbian\bin\;C:\NokiaQtSDK\mingw\bin;c:\NokiaQtSDK\Symbian\SDK\perl\bin\;C:\qt-mobility-symbian-opensource-1.1.0\lib\;C:\Git\cmd

    QTDIR
    C:\Qt\4.7.1-symbian

    I have explicity specified QT_MOBILITY_PREFIX in mapviewer.pro
    QT_MOBILITY_PREFIX = C:/qt-mobility-symbian-opensource-1.1.0

    When viewing S60 SDK tab in Qt Creator I see error:
    The file 'devices.xml' containing the device SDK configuration could not be found looking at the registry key HKEY_LOCAL_MACHINE\Software\Symbian\EPOC SDKs\CommonPath or the common program data directories.

    (If I remember correctly it was messed up by Qt4.7 installer)

    Generated Makefile http://pastebin.com/KcwMtegG
    Build log for Symbian: http://pastebin.com/raw.php?i=wTtMy6ML
    Build log for Win7 64bit http://pastebin.com/raw.php?i=YAhtq0RS

  2. #2
    Registered User
    Join Date
    Jul 2010
    Posts
    5

    Re: Mapviewer from Mobility 1.1.0 requires QtMobility 1.0.2(0) during installation?

    Seems that I have messed up Symbian SDK as NokiaQtSDK\Symbian\SDK\mkspecs\features mobility.prf and mobilityconfig.prf contain references to mobility 1.2.0. As my installation on win7 64b seemes to be broken anyway (missing mobility headers) I will make clean install.

    Can anybody confirm that they have working mapviewer example on Symbian phone? I compiled mapviewer under Ubuntu, but it crashes on phone

  3. #3
    Registered User
    Join Date
    Jul 2010
    Posts
    5

    Re: Mapviewer from Mobility 1.1.0 requires QtMobility 1.0.2(0) during installation?

    Success, I now have running mapviewer example in my Nokia E51. It took me 2 weekends and many evenings to get example running (I still don't have simulator or debugger). My findings:

    * Nokia QtSDK 1.0.2 + Qt 4.7.1 + Mobility 1.1.0 results in broken installation on Win7 64 bit (I did clean install and still lot's of warnings and missing headers)
    * I used Remote Compiler on win7 and/or GnuPoc installation on Linux http://lizardo.wordpress.com/2010/10...eator-support/
    * I also had to do clean install on phone to get things running (full firmware update to get rid of old Qt libraries)
    * I had to sign mapviewer with Open Online Signing https://www.symbiansigned.com/app/pa...ignedOnline.do

    Althoug I like Qt APis, it's very deep learning curve to get non basic example running on real hardware. It took me ~40 hours to set up basic tools - I still don't have simulator or debugger.
    Last edited by jannok; 2010-11-15 at 22:36. Reason: typo

Similar Threads

  1. Qt Mobility 1.1 Installation error
    By Marie_Kay in forum [Archived] Qt Mobility Project
    Replies: 3
    Last Post: 2010-11-13, 20:39
  2. Mobility pack 6.8 installation help
    By Anamika in forum Mobile Java Tools & SDKs
    Replies: 1
    Last Post: 2010-09-21, 11:48
  3. Qt mobility installation
    By Zedster in forum [Archived] Qt Mobility Project
    Replies: 3
    Last Post: 2010-04-15, 16:59
  4. Installation of QtMobility on WinCE
    By ash_21 in forum [Archived] Qt Mobility Project
    Replies: 21
    Last Post: 2010-02-15, 17:03

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •