×

Discussion Board

Results 1 to 5 of 5
  1. #1
    Registered User
    Join Date
    Mar 2009
    Posts
    5

    BUG in Symbian^3 "Advanced VoIP Settings"?

    Using NOKIAs VoIP Client since an E65 some years ago up to use this service in an N86 and now the N8 I observed this strange behaviour when setting up a new VoIP service:

    Unfortunately the "Advanced VoIP Settings" for Symbian^3 seem to have a BUG compared with the earlier versions for earlier Symbian versions. I use an N86 and voip just works fine there - even over VPN tunneled to my home SIP and VPN server.

    The bug is in the configuration of the SIP profiles / VoIP services.



    On N86 you may first configure a SIP profile (incl. a single individual "default access point"), then switch to "Advanced VoIP Settings > create new service" and you will find there the newly created SIP account to activate as a "service".

    Or you may do it the other way round: Go to "Advanced VoIP Settings > create new service" and configure there the basic data of your SIP profile (public user name and password). This creates a SIP Profile where you only need to configure either a "default destination" for access or a single individual "default access point".



    Now, on N8 when I configure a SIP Profile first and then create the corresponding VoIP service I can do this - BUT TO THIS VOIP SERVICE I CANNOT LOGIN!



    If creating the service the other way round > creating the VoIP Service and thus creating the corresponding SIP Profile in THIS SIP PROFILE NO INDIVIDUAL "DEFAULT ACCESS POINT" CAN BE CHOSEN - "INTERNET" IS PREDETERMINED AS "DEFAULT DESTINATION" AND CANNOT BE CHANGED (unless you configure also VPN - in this case you can also choose "intranet" instead of "internet").



    The possibility to configure an individual "default access point" in a SIP Profile is in certain circumstances important when using VPN!

  2. #2
    Nokia Developer Expert
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,142

    Re: BUG in Symbian^3 "Advanced VoIP Settings"?

    first thing you could do, is to try compiling the code with Symbian^3 SDK, and see whether it has any differences. Then if it still does not work, see from the symbian foundation source codes whether you are uisng it correctly (basically find a place where the API is used and try copying the code)

    And if it still does not work, then you could always make a bug report.

  3. #3
    Registered User
    Join Date
    Mar 2009
    Posts
    5

    Re: BUG in Symbian^3 "Advanced VoIP Settings"?

    Thx for this quick reply. Before digging deeper one more simple question just for evaluation of my observation: Is the observed behaviour "normal" and "general" in N8 setting up VoIP services in S^3?
    Greetings to Bangkok - lived there for a few years.

  4. #4
    Registered User
    Join Date
    Mar 2009
    Posts
    5

    Re: BUG in Symbian^3 "Advanced VoIP Settings"?

    Got the -certainly somewhat surprising- solution here.

  5. #5
    Registered User
    Join Date
    Jun 2008
    Posts
    19

    Re: BUG in Symbian^3 "Advanced VoIP Settings"?

    Try first to create another destination, e.g. 'VoIP' and set / include some access points in it.
    Afterwords you can change the default destination from 'Internet' to 'VoIP', etc.

Similar Threads

  1. Advanced VOIP settings on E72
    By nemric in forum VoIP
    Replies: 15
    Last Post: 2010-10-12, 13:30
  2. Advanced SIP VoIP Settings disappeared
    By fredlcore in forum VoIP
    Replies: 1
    Last Post: 2010-10-02, 14:49
  3. report bug on "Symbian OS Email Version 6.1"
    By gemal in forum Symbian Networking & Messaging (Closed)
    Replies: 1
    Last Post: 2005-10-06, 14:04
  4. Nokia 7210 SDK Bug: TextField.NUMERIC allows "w" and "p"
    By vizionari in forum Mobile Java Tools & SDKs
    Replies: 1
    Last Post: 2003-05-12, 14:33
  5. Replies: 1
    Last Post: 1970-01-01, 02:00

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •