×

Discussion Board

Results 1 to 4 of 4
  1. #1
    Super Contributor
    Join Date
    May 2006
    Location
    Beijing,China
    Posts
    1,190

    Does N8 and N97 support QT quick

    I saw some information about QT quick, and it seems that this new development tool is very powerful and easy to use.

    Thus I wonder to know does N8 and N97 support QT quick?
    [I][COLOR="Orange"]xhsoldier[/COLOR][/I]
    [email]xhsoldier@gmail.com[/email]/[email]xhsoldier@163.com[/email]

  2. #2
    Nokia Developer Champion
    Join Date
    Feb 2008
    Location
    Ahmedabad, Gujarat, India
    Posts
    3,852

    Re: Does N8 and N97 support QT quick

    hello xhsoldier

    QtQuick is introduced with Qt 4.7 and yes AFAIK N8 supports QtQuick. I have run some sample examples over that , which looks good.

    I am not sure about N97. But still the NokiaQtSDK doesnt support Qt 4.7 for symbian devices.

  3. #3
    Registered User
    Join Date
    Mar 2009
    Posts
    5

    Re: Does N8 and N97 support QT quick

    Yes, N97 supports Qt Quick if you have the Qt 4.7 .sis package installed in your N97. Although NokiaQtSDK comes with Qt 4.6.3 for Symbian which does not support "Qt Quick" Symbian applications. You have to separately install Qt 4.7 for Symbian on your PC and then add the new Qt version to your Qt Creator. You should also install the qt.sis files in your installation folder(in my case P:\Qt\Qt4.7-Symbian) to your N97 phone. In this way your N97 now supports Qt Quick.
    Point of observation, because you can create QML Projects in Qt Creator does not mean you can actually make the QML install on your N97. There are different procedures in creating signed sis files of the QML Project to your Symbian device(N97). if you need more instructions you can ask me.

  4. #4
    Registered User
    Join Date
    Mar 2009
    Posts
    5

    Re: Does N8 and N97 support QT quick

    This is for N8 (Symbian ^3)developers...
    The Qt 4.6.3 version is pre-installed in the N8 and a update to Qt4.7 is now possible, so check out this article, it has instructions on how to "update" your N8 to be Qt 4.7 "QML" compatible.
    http://wiki.forum.nokia.com/index.ph...eloper_version

    Ask if you have more questions.
    Best of Luck.

Similar Threads

  1. N8 going to be next N97
    By drjamit in forum General Development Questions
    Replies: 10
    Last Post: 2010-12-21, 16:49
  2. Qt Quick
    By davidmaxwaterman in forum Nokia N9
    Replies: 8
    Last Post: 2010-07-02, 05:08
  3. Tools for quick start with Qt for Symbian
    By mbnoimi in forum [Archived] Nokia Smart Installer for Symbian
    Replies: 6
    Last Post: 2010-02-22, 16:08

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×