×

Discussion Board

Results 1 to 2 of 2
  1. #1
    Regular Contributor
    Join Date
    May 2009
    Location
    sydney
    Posts
    117

    Exclamation Is it a bug in N8? can't retrieve NetworkName value via SysInfo.

    this is a very simple code of using platformService2.js file that I assume it will work to capture the Operator name. It works under N97 but fails in N8.

    Is it a bug in N8??

    Code:
    var so;
    
    //ErrorCallback funtion.
    
      function errorCB(err){
      alert('ErrrorCode:'+err.code+'ErrorMessage:'+err.message);
      }
    
    //success callback funtion.
    
       function successCB(dataMap) {
       //Few name-value pairs are mentioned here. 
       alert("Operator Name: " + dataMap.networkName);
       alert("Status: " + dataMap.networkStatus);
       alert("cellId: " + dataMap.cellId);
    
       alert("Time of data retrieval: " +dataMap.time);
     }
    
    try {
    
       so = nokia.device.load("sysinfo");
        
       var channelName = "Network";
       //Channel name and its system data are obtained using channels method
         
       var id = so.getChannel(channelName,successCB,errorCB);
    } catch(e) {
    
       alert(e);
    }
    code from url http://library.forum.nokia.com/index...78683B818.html
    Nokia is back!

  2. #2
    Regular Contributor
    Join Date
    May 2009
    Location
    sydney
    Posts
    117

    Re: Is it a bug in N8? can't retrieve NetworkName value via SysInfo.

    new updates,
    tried different sims on my N8, use a sim wiht "3" Australia and it works, but swich to "Vodafone" it just fails, it might be something relate to Sim, however, they both working fine under N97.

    It is a bug for N8 i guess.
    Last edited by wenz; 2010-11-17 at 23:13.
    Nokia is back!

Similar Threads

  1. Nokia N8 PUSH-MAIL Bug/Problem,need to solve urgently
    By saurabh1mukhekar in forum General Development Questions
    Replies: 3
    Last Post: 2010-11-11, 08:44
  2. Bug in Nokia N8 SSL implementation in JavaME
    By bjorn911 in forum Series 40 & S60 Platform Feedback Archive
    Replies: 3
    Last Post: 2010-11-01, 09:19
  3. Major bug in N8
    By jitu_goldie in forum Series 40 & S60 Platform Feedback Archive
    Replies: 3
    Last Post: 2010-10-20, 19:06
  4. N80 sysinfo BUG?
    By leban in forum Symbian
    Replies: 2
    Last Post: 2006-11-30, 08:03
  5. retrieve-status issue in m-retrieve.conf pdu
    By xiangjb in forum General Messaging
    Replies: 0
    Last Post: 2002-12-14, 00:48

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×