×

Discussion Board

Results 1 to 2 of 2
  1. #1
    Super Contributor
    Join Date
    Mar 2003
    Posts
    2,426

    Operator Logo problems

    I have sent TDMA Smart Messages (text-based) to my 8310 (GSM) and most of them seem to work except for the operator logo. Logo is received by the phone but the logo that comes out is not correct. The problem does not seem to lie with the OTA Bitmap data (since different bitmap data gave the same incorrect logo) but rather the header to the message. Since the TDMA Document did not show any examples of operator logos, maybe it is not supported by the phone.

    Message sent was of the form:
    //SCKL15820000010201 3005F5200A00480E01...

    MCC = 505
    MNC = 02

    Any help would be appreciated. Thanks

    Posted by y y, yyjy1@yahoo.com
    on January 26, 2002 at 08:32

  2. #2
    Super Contributor
    Join Date
    Mar 2003
    Posts
    2,426

    RE: Operator Logo problems

    Posted by Forum Nokia Developer Support,
    on January 29, 2002 at 08:57

    Hello. There are at least a couple of issues here, and unfortunately I don't exactly know the answer yet. One is that my understanding was that using MCC and MNC was not supported in TDMA. The other is that there is no way you can possibly get your 72x14 operator logo to fit in two messages if you're sending it as described below. In place of each byte that would be sent in GSM you are sending two. (e.g. One to represent the character "F" (46h) and another to represent the character "5" (35h), whereas in GSM, you would simply send F5h.)

    I would suggest starting out with a much smaller logo (one that would fit in a single message for you), and in the meantime, I'll try to get a more definite answer for you.

    :Message sent was of the form:
    ://SCKL15820000010201 3005F5200A00480E01...

    Forum Nokia Developer Support

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×