×

Discussion Board

Results 1 to 4 of 4
  1. #1
    Registered User
    Join Date
    Nov 2010
    Posts
    8

    Exclamation HttpRequest problem in Nokia c3-00

    Hi, I’m having trouble with a HttpRequest in the c3-00. In the emulators there is no problem, but when I deploy the application the device says that it's searching for a Bluetooth device, i have WiFi enabled and I've tested the internet conection in the device and it works fine. I’m using Series 40 6th Edition SDK.

    Here is the code of the conection

    Code:
    HttpConnection conn;
    conn = (HttpConnection)Connector.open(url);
    InputStream xmlStream = conn.openInputStream();
    InputStreamReader isr = new InputStreamReader(xmlStream);

    Thanks.

  2. #2
    Super Contributor
    Join Date
    Mar 2008
    Location
    The Capital of INDIA
    Posts
    4,328

    Re: HttpRequest problem in Nokia c3-00

    Quote Originally Posted by frco.marin View Post
    Hi, I’m having trouble with a HttpRequest in the c3-00. In the emulators there is no problem, but when I deploy the application the device says that it's searching for a Bluetooth device, i have WiFi enabled and I've tested the internet conection in the device and it works fine. I’m using Series 40 6th Edition SDK.

    Here is the code of the conection



    Code:
    HttpConnection conn;
    conn = (HttpConnection)Connector.open(url);
    InputStream xmlStream = conn.openInputStream();
    InputStreamReader isr = new InputStreamReader(xmlStream);

    Thanks.
    Hi marin,

    I guess there is some confusion in your post, if you are making Http connection, thenn how the red lines in the above quoted area can be asked?

    I will appriceate if you could come with the more details and the exact message that the device dispayed?
    Thanks with Regards,

    R a j - The K e r n e l


    Join Delhi-NCR Nokia Developer's Community,

  3. #3
    Registered User
    Join Date
    Nov 2010
    Posts
    8

    Re: HttpRequest problem in Nokia c3-00

    Hi, Raj thanks for the response, when i ran the same code in the emulator it works fine, it makes the httpresponse, but when i deploy the application instead of asking me if i allow the application to connect to the internet it only said that is searching for a Bluetooth device. Also if i deploy the example of localization of nokia i get the same message. I’m wondering if I need to do something extra to use httpresponse in the device?

    The message is:
    No device found check that the device you are searching for has a Bluetooth switched on and set visible. Then it throws an application error: Null Pointer java/lang/NullPointerException.
    But im not using any Bluetooth connection y only use httpresponse.

    Thanks.

  4. #4
    Registered User
    Join Date
    Nov 2010
    Posts
    8

    Re: HttpRequest problem in Nokia c3-00

    Hi, after some work i figured out what was happening, the problem is not the httprequest is the localization API that throws that problem. Does some body have the same problem? I try to run the localization examples of nokia but they also gave me the same message. Does the c3-00 support localization? In the device details http://www.forum.nokia.com/Devices/D...cations/C3-00/ says that it can.

    Thanks

Similar Threads

  1. Replies: 4
    Last Post: 2011-01-13, 17:14
  2. how to increase power saver mode duration on nokia-C3-00
    By catavanana in forum General Development Questions
    Replies: 2
    Last Post: 2010-11-14, 08:37
  3. Replies: 8
    Last Post: 2010-10-31, 01:11
  4. C3-00 phone identification via User Agent
    By djsmev in forum Mobile Java Games
    Replies: 3
    Last Post: 2010-10-22, 07:03

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •