×

Discussion Board

Results 1 to 3 of 3
  1. #1
    Registered User
    Join Date
    Aug 2008
    Posts
    9

    Failed because of "Outdated version of Qt Mobility"

    Hi,

    some of my files recently failed QA because of the following error:

    "Unfortunately, we are unable to distribute your content because the submitted content is using an outdated version of Qt Mobility. Please rebuild and resubmit using the latest version of Qt Mobility."

    I am very confident that my content is using version 1.0.2 of Qt Mobility which i believe is the latest version that is accepted for Ovi Store content. I have emailed Ovi publish about the error but I was wondering if anyone here had had the same error and had an answer as to how to resolve it.
    Does anyone know a command that would tell me which version of Qt Mobility my program was built with?
    Also, is there a single updated place that I could look to tell me which version of Qt and Qt Mobility I should be using for each platform as I expect this will change with time?

    thanks for your time,

    Matt

  2. #2
    Registered User
    Join Date
    Mar 2010
    Posts
    61

    Re: Failed because of "Outdated version of Qt Mobility"

    There's a macro that tells you which version you're building with (QTM_VERSION_STR or something). Also check the smart installer wiki to see what the UID for QtM 1.0.2 is and make sure that it's the same as what you have in your pkg dependencies.

  3. #3
    Registered User
    Join Date
    Aug 2008
    Posts
    9

    Re: Failed because of "Outdated version of Qt Mobility"

    Hi,

    thanks for your reply.

    It seems that whilst I had installed version 1.0.2 to my Symbian SDK, I had failed to build Qt Mobility itself which meant that the version provided to the installation process by the file C:\Qt\4.6.3\mkspecs\features\mobility.prf was still 1.0.1.
    I have since built QtMobility 1.0.2 and this has fixed the problem.

    Thanks again for the speedy reply,

    Matt

Similar Threads

  1. Replies: 9
    Last Post: 2010-10-25, 09:21
  2. Qt/3D with QML bindings - "module "Qt3D" is not installed"
    By John de Witt in forum [Archived] Qt SDKs and Tools
    Replies: 0
    Last Post: 2010-10-20, 04:53
  3. Replies: 3
    Last Post: 2010-06-30, 01:17
  4. WML - Error "Operation failed" / "your application is too large"
    By crajesh_2985 in forum Mobile Java Tools & SDKs
    Replies: 3
    Last Post: 2009-10-06, 12:31

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×