×

Discussion Board

Page 1 of 2 12 LastLast
Results 1 to 15 of 20
  1. #1
    Regular Contributor
    Join Date
    Aug 2008
    Posts
    56

    Problem installing Qt Mobility 1.1.0

    So following instructions at http://doc.qt.nokia.com/qtmobility-1...tallation.html
    I downloaded latest Qt Mobility 1.1.0 and extracted it's contents to
    C:\qtmobility\qt-mobility-opensource-src-1.1.0\
    Next I opened commandline and typed
    cd c:\QtMobility\qt-mobility-opensource-src-1.1.0
    configure

    So it started doing something, at first it was like this:
    http://uppix.net/4/2/d/41501688e6ab0...b35025be81.png
    and then like this
    http://uppix.net/a/3/f/a27e0bd08b03a...6dc05080e9.png

    And this happens always, guess it failed. Any help please?

  2. #2
    Super Contributor
    Join Date
    Mar 2004
    Location
    Singapore
    Posts
    9,968

    Re: Problem installing Qt Mobility 1.1.0

    It has been discussed some days back (asked by me) solution is

    1. you can get those modules (no clue from where)
    2. just ignore the warning and move on.

  3. #3
    Registered User
    Join Date
    Aug 2010
    Posts
    21

    Re: Problem installing Qt Mobility 1.1.0

    NokiaQtSDK + Qt Mobility 1.1.0 work together?
    i do sis from examples\camera,
    but in simulator have problem - :: error: cannot find -lQtMobilitySimulator :: error: collect2: ld returned 1 exit status

    how start app in simulator?

  4. #4
    Registered User
    Join Date
    Oct 2010
    Posts
    18

    Re: Problem installing Qt Mobility 1.1.0

    Hi,
    I am also facing the same problem. I have "S60_5th_Edition_SDK_v1.0" installed.
    I have followed these steps:
    1. Downloaded the Qt Mobility API. Unpacked at location : "E:\S60\qt-mobility-symbian-opensource-1.1.0"
    2. I run the "configure" command which gave me following errors :
    Checking LBT
    ... Not Found
    Checking SNAP
    ... Not Found
    ...........................(Some more APIs)
    ...........................
    Checking S60_Sensor_API
    ... Not Found
    .........................................
    Final Error is : "Project ERROR: Must have a Symbian sensor backend available"
    "configure failed."

    Please provide solution. I am unable to build even simple application which is provided in quick start example.

    Thanks in advance.

  5. #5
    Regular Contributor
    Join Date
    Aug 2008
    Posts
    56

    Re: Problem installing Qt Mobility 1.1.0

    Quote Originally Posted by skumar_rao View Post
    It has been discussed some days back (asked by me) solution is

    1. you can get those modules (no clue from where)
    2. just ignore the warning and move on.
    If you checked second pic, you see it says "configure failed" in the end, so ignoring it won't help...

  6. #6
    Super Contributor
    Join Date
    Mar 2004
    Location
    Singapore
    Posts
    9,968

    Re: Problem installing Qt Mobility 1.1.0

    Quote Originally Posted by Arvis17 View Post
    If you checked second pic, you see it says "configure failed" in the end, so ignoring it won't help...
    yes it helps in make will just skip those modules same problem discussed with 1.1.0 TP http://discussion.forum.nokia.com/fo...ian&highlight=

  7. #7
    Regular Contributor
    Join Date
    Aug 2008
    Posts
    56

    Re: Problem installing Qt Mobility 1.1.0

    No luck, there is no makefile, so sommand "nmake" fails, I can't believe there's none who got solution for this...

  8. #8
    Registered User
    Join Date
    Oct 2010
    Posts
    18

    Re: Problem installing Qt Mobility 1.1.0

    Hi, I am unable to see your images.

    Have you tried configuring modules separately ???
    try this command : configure -modules "systeminfo"

    If it succeeds then try building QuickStart App.

    -Aditya

  9. #9
    Regular Contributor
    Join Date
    Aug 2008
    Posts
    56

    Re: Problem installing Qt Mobility 1.1.0

    Thanks, you got me going forward!
    Now after I configured (multimedia module I did, since that was the one I need)
    Then I typed 'make' some processes happened, guess all was as it should be and then I typed 'make install'
    which says "make: *** No rule to make target 'install'. Stop."
    I ignored it and went to Qt Creator, created new project, included multimedia in .pro file and in code, typed

    #include <QCamera>

    But when building I get "QCamera: No such file or directory"
    And yes I have set the PATH variable to "C:\qtmobility\qt-mobility-opensource-src-1.1.0\lib"

    So any ideas of what I'm doing wrong or should do to fix this?

  10. #10
    Registered User
    Join Date
    Oct 2010
    Posts
    18

    Re: Problem installing Qt Mobility 1.1.0

    Quote Originally Posted by Arvis17 View Post
    Thanks, you got me going forward!
    Now after I configured (multimedia module I did, since that was the one I need)
    Then I typed 'make' some processes happened, guess all was as it should be and then I typed 'make install'
    which says "make: *** No rule to make target 'install'. Stop."
    I ignored it and went to Qt Creator, created new project, included multimedia in .pro file and in code, typed

    #include <QCamera>

    But when building I get "QCamera: No such file or directory"
    And yes I have set the PATH variable to "C:\qtmobility\qt-mobility-opensource-src-1.1.0\lib"

    So any ideas of what I'm doing wrong or should do to fix this?
    I have tried the same thing that you did and it is working fine here.

    1. >configure -modules multimedia
    2. >make

    then #include<QCamera> in QT and it build successfully.

  11. #11
    Regular Contributor
    Join Date
    Aug 2008
    Posts
    56

    Re: Problem installing Qt Mobility 1.1.0

    Yeah I did the same, maybe it could have some problem with older version of Mobility which already is in SDK?

  12. #12
    Registered User
    Join Date
    Oct 2010
    Posts
    18

    Re: Problem installing Qt Mobility 1.1.0

    Quote Originally Posted by Arvis17 View Post
    Yeah I did the same, maybe it could have some problem with older version of Mobility which already is in SDK?
    Are you able to run the QuickStart App which I mentioned in my previous post ?
    > configure -modules "systeminfo"
    Then try this QuickStart App

  13. #13
    Registered User
    Join Date
    Dec 2010
    Posts
    2

    Re: Problem installing Qt Mobility 1.1.0

    There is a file "INSTALL.symbian" in the Qt Mobility package that describes the steps you need to take to install this on Windows.
    The library is already pre built and included as a zip in the installation folder. So you have to extract this file to your Symbian SDK.
    And then copy the <QTMOBILITYDIR>/features/mobility.prf.template file to QTDIR/mkspecs/features/mobility.prf
    So you should not have to run configure and build the package.

  14. #14
    Registered User
    Join Date
    Oct 2010
    Posts
    18

    Re: Problem installing Qt Mobility 1.1.0

    Quote Originally Posted by mpeters View Post
    There is a file "INSTALL.symbian" in the Qt Mobility package that describes the steps you need to take to install this on Windows.
    The library is already pre built and included as a zip in the installation folder. So you have to extract this file to your Symbian SDK.
    And then copy the <QTMOBILITYDIR>/features/mobility.prf.template file to QTDIR/mkspecs/features/mobility.prf
    So you should not have to run configure and build the package.
    Hey thanx for this.
    It was really very simple. No documentation mentioed about this.

    Arvis17 have you tried this ?

  15. #15
    Registered User
    Join Date
    Apr 2010
    Posts
    7

    Re: Problem installing Qt Mobility 1.1.0

    Hello everybody.

    Reading this thread, I got an idea that I am completely lost in this topic. Could please anyone of you provide society with step-by-step installation guide? I am asking you to help because I really have no idea how to make it works... Thank you in advance.

Page 1 of 2 12 LastLast

Similar Threads

  1. error installing qt-mobility with qt 4.7 on Windows 7
    By kaycee1 in forum [Archived] Qt SDKs and Tools
    Replies: 0
    Last Post: 2010-09-24, 02:18
  2. installing QT Mobility
    By tadu in forum [Archived] Qt SDKs and Tools
    Replies: 9
    Last Post: 2010-08-26, 06:39
  3. Building Qt-mobility libs and installing on phone
    By jmclaurin11 in forum [Archived] Qt Mobility Project
    Replies: 2
    Last Post: 2010-04-30, 00:49
  4. Problem when installing qt-mobility extension
    By pta0007 in forum [Archived] Qt Mobility Project
    Replies: 6
    Last Post: 2010-02-02, 23:49
  5. Installing Mobility Project Problem
    By kashifk2009 in forum [Archived] Qt Mobility Project
    Replies: 4
    Last Post: 2009-12-19, 17:38

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •