×

Discussion Board

Page 1 of 2 12 LastLast
Results 1 to 15 of 16

Hybrid View

  1. #1
    Registered User
    Join Date
    Nov 2010
    Posts
    4

    Nokia X3-02 with VOIP other than Gizmo5

    Many many thanks to sudude and traud. I can confirm that my Nokia X3-02 VOIP work perfectly configured with .xml file from this post, just replacing the name of the voip provider (Justvoip), username and password.

    I tried n0kvoip but when activate the service it is rejected by justvoip....didn't work for me. I've contact and send them my *.xml file and they promised that in the next version will make some changes so I think it will work, still not tried.

    Here are some Justvoip settings:

    SIP port : 5060
    Registrar : sip.justvoip.com
    Proxy server : sip.justvoip.com
    Outbound proxy server : leave empty
    Account name : your JustVoip username
    Password : your JustVoip password
    Display name/number : your JustVoip username or voipnumber
    Stunserver (option) : stun.justvoip.com
    If you have audio problems:
    Use a STUN server (e.g. stun.justvoip.com) with port 3478 (if supported by your device)
    Use the G.711 codec

    Here is example .xml file for the phone CLICK

    Thank you again

    Here is the working .xml content:

    <?xml version="1.0"?>
    <!DOCTYPE wap-provisioningdoc PUBLIC "-//WAPFORUM//DTD PROV 1.0//EN"
    "http://www.wapforum.org/DTD/prov.dtd">
    <wap-provisioningdoc version="1.1">
    <!-- XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX-->
    <characteristic type="BOOTSTRAP">
    <parm name="NAME" value="justvoip" />
    </characteristic>
    <!-- XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX-->
    <!-- Nokia S40 v72 VoIP settings, w9013 -->
    <characteristic type="APPLICATION">
    <parm name="APPID" value="w9013"/>
    <parm name="PROVIDER-ID" value="justvoip"/>
    <parm name="NAME" value="justvoip"/>
    <parm name="TO-NAPID" value="INTERNET"/>
    <parm name="TO-APPREF" value="justvoip_SIP_settings"/>
    <parm name="SMPORT" value="16384"/>
    <parm name="EMPORT" value="32766"/>
    <parm name="MEDIAQOS" value="46"/>
    <parm name="SECURECALLPREF" value="0"/>
    <parm name="RTCP" value="0"/>
    <parm name="MOMAXALERT" value="45"/>
    <parm name="MTMAXALERT" value="30"/>

    <!-- AMR NB -->
    <characteristic type="CODEC">
    <parm name="MEDIASUBTYPE" value="0"/>
    <parm name="PRIORITYINDEX" value="0"/>
    <parm name="OCTET-ALIGN"/>
    <parm name="VAD"/>
    </characteristic>

    <!-- G.729 with default values -->
    <characteristic type="CODEC">
    <parm name="MEDIASUBTYPE" value="10"/>
    <parm name="PRIORITYINDEX" value="1"/>
    <parm name="ANNEXB"/>
    </characteristic>

    <!-- G711 a-law with default values -->
    <characteristic type="CODEC">
    <parm name="MEDIASUBTYPE" value="3"/>
    <parm name="PRIORITYINDEX" value="2"/>
    <parm name="VAD"/>
    </characteristic>

    <!-- G711 u-law with default values -->
    <characteristic type="CODEC">
    <parm name="MEDIASUBTYPE" value="4"/>
    <parm name="PRIORITYINDEX" value="3"/>
    <parm name="VAD"/>
    </characteristic>

    <!-- G.726-40 with default values -->
    <characteristic type="CODEC">
    <parm name="MEDIASUBTYPE" value="5"/>
    <parm name="PRIORITYINDEX" value="4"/>
    <parm name="VAD"/>
    </characteristic>

    <!-- G.726-32 with default values -->
    <characteristic type="CODEC">
    <parm name="MEDIASUBTYPE" value="6"/>
    <parm name="PRIORITYINDEX" value="5"/>
    <parm name="VAD"/>
    </characteristic>

    <!-- G.726-24 with default values -->
    <characteristic type="CODEC">
    <parm name="MEDIASUBTYPE" value="7"/>
    <parm name="PRIORITYINDEX" value="6"/>
    <parm name="VAD"/>
    </characteristic>

    <!-- G.726-16 with default values -->
    <characteristic type="CODEC">
    <parm name="MEDIASUBTYPE" value="8"/>
    <parm name="PRIORITYINDEX" value="7"/>
    <parm name="VAD"/>
    </characteristic>

    <!-- CN Comfort noise with default values -->
    <characteristic type="CODEC">
    <parm name="MEDIASUBTYPE" value="9"/>
    <parm name="PRIORITYINDEX" value="8"/>
    </characteristic>

    </characteristic>

    <!-- XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX-->
    <!-- NAT/FW settings, w902E -->
    <characteristic type="APPLICATION">
    <parm name="APPID" value="w902E"/>
    <parm name="NAME" value="NAT/FW Traversal settings"/>
    <characteristic type="NW">
    <parm name="APPREF" value="justvoip_NAT_FW_settings"/>
    <parm name="DOMAIN" value="sip.justvoip.com"/>
    <parm name="STUNSRVADDR" value="0.0.0.0"/>
    <parm name="STUNSRVPORT" value="3478"/>
    <parm name="NATREFRESHTCP" value="30"/>
    <parm name="NATREFRESHUDP" value="20"/>
    </characteristic>
    <characteristic type="NATIAP">
    <parm name="TO-NAPID" value="INTERNET"/>
    <parm name="REFRESHTCP" value="1200"/>
    <parm name="REFRESHUDP" value="28"/>
    <parm name="STUNRETRANSMIT" value="250"/>
    </characteristic>
    </characteristic>

    <!-- XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX-->
    <!-- SIP settings, w9010 -->
    <characteristic type="APPLICATION">
    <parm name="APPID" value="w9010"/>
    <parm name="APPREF" value="justvoip_SIP_settings"/>
    <parm name="PROVIDER-ID" value="justvoip"/>
    <parm name="TO-NAPID" value="INTERNET"/>
    <parm name="PTYPE" value="IETF"/>
    <parm name="PUID" value="sip:USERNAME@justvoip.com"/>
    <parm name="APROTOCOL" value="UDP" />
    <!-- Outbound settings -->
    <characteristic type="APPADDR">
    <parm name="LR"/>
    <parm name="ADDR" value="sip.justvoip.com"/>
    <characteristic type="PORT">
    <parm name="PORTNBR" value="5060" />
    </characteristic>
    </characteristic>
    <!-- Outbound credentials -->
    <characteristic type="APPAUTH">
    <parm name="AAUTHNAME" value="USERNAME"/>
    <parm name="AAUTHSECRET" value="PASSWORD"/>
    <parm name="AAUTHDATA" value=""/>
    <parm name="AAUTHTYPE" value="HTTP-DIGEST" />
    </characteristic>
    <!-- Registrar location and credentials -->
    <characteristic type="RESOURCE">
    <parm name="URI" value="sip.justvoip.com"/>
    <parm name="AAUTHNAME" value="USERNAME"/>
    <parm name="AAUTHSECRET" value="PASSWORD"/>
    <parm name="AAUTHDATA" value=""/>
    <parm name="AAUTHTYPE" value="HTTP-DIGEST" />
    </characteristic>
    </characteristic>

    <!-- XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX-->
    </wap-provisioningdoc>
    Last edited by stambo98; 2011-01-02 at 00:14.

  2. #2
    Registered User
    Join Date
    Dec 2010
    Posts
    2

    Re: Nokia X3-02 with VOIP other than Gizmo5

    what is your access point : WLAN or 3G.
    I cannot make it to work with 3G.
    Any advice is appreciated.
    Thanks you

  3. #3
    Registered User
    Join Date
    Jun 2008
    Posts
    44

    Re: Nokia X3-02 with VOIP other than Gizmo5

    @stambo98: your XMl template is for 6300i, there are some new stuff in X3-02. See, http://www.forum.nokia.com/info/sw.n...s_Example.html

    @khurshidiqbalindia: The X3-02 VoIP documentation (http://wiki.forum.nokia.com/index.ph..._documentation) or user guide do not mention anything about VoIP working over 3G, they just mention WiFi. So apparently it does not support VoIP over 3G

  4. #4
    Registered User
    Join Date
    Dec 2010
    Posts
    2

    Re: Nokia X3-02 with VOIP other than Gizmo5

    Hi Sudude,

    Thanks for info,

    I built my voip setting with WLAN and now i am getting this message " WLAN not available for this account".
    but I can connect to my WLAN and browse internet / check for updates. etc

    any help will be appreciated. Please help to modify the settings in xml file.

    thanks

  5. #5
    Registered User
    Join Date
    Jun 2008
    Posts
    44

    Re: Nokia X3-02 with VOIP other than Gizmo5

    Could you share the XML with which you get the error note

  6. #6
    Registered User
    Join Date
    Nov 2010
    Posts
    4

    Re: Nokia X3-02 with VOIP other than Gizmo5

    Quote Originally Posted by sudude View Post
    @stambo98: your XMl template is for 6300i, there are some new stuff in X3-02. See, http://www.forum.nokia.com/info/sw.n...s_Example.html
    Yes it is for 6300i but works very fine on my wifes X3-02, the example files are incomprehensible for me dont have time to compare and adjust them if somebody does please lets share it. Happy New Year to all :-))

  7. #7
    Registered User
    Join Date
    Dec 2010
    Posts
    1

    Re: Nokia X3-02 with VOIP other than Gizmo5

    I'm just confirming that n0kVoIP settings work for me on the Nokia X3-02 Touch and Type phone.

    I can only connect to VoIP server through wifi connection. I thought it might be some settings that nokvoip has so I went through the xml file and adjusted settings. Again, all I get is connection is only possible through wifi.

    If anyone has successfully connected to their VoIP Service Provider through a 3G connection. Please share what you've done. Thanks.

  8. #8
    Registered User
    Join Date
    Apr 2011
    Posts
    1

    Re: Nokia X3-02 with VOIP other than Gizmo5

    Quote Originally Posted by yorkhoh View Post
    I'm just confirming that n0kVoIP settings work for me on the Nokia X3-02 Touch and Type phone.

    I can only connect to VoIP server through wifi connection. I thought it might be some settings that nokvoip has so I went through the xml file and adjusted settings. Again, all I get is connection is only possible through wifi.

    If anyone has successfully connected to their VoIP Service Provider through a 3G connection. Please share what you've done. Thanks.
    Can someone try to add in the:

    <!-- Nokia S40 v72 VoIP settings, w9013 -->

    Section the following parameter:
    <parm name="WCDMA" value="1"/>

    test and report back

    Thanks,

  9. #9
    Registered User
    Join Date
    Jun 2008
    Posts
    44

    Re: Nokia X3-02 with VOIP other than Gizmo5

    Have tried different params, like the one used in S60 without any luck. I have come to the conclusion that X3-02 does not support VoIP over 3G. This would be also in line with the VoIP documentation (http://wiki.forum.nokia.com/index.ph..._documentation) which only talks about WiFi as the connectivity technology.

    Btw X3-02 is using the v92 VoIP version, there are some improvements like HD voice which sounds pretty nice

  10. #10
    Registered User
    Join Date
    Mar 2003
    Posts
    4,105

    Re: Nokia X3-02 with VOIP other than Gizmo5

    prakkrish, although not targeted for Series 40, still I recommend to go through this document. You might have an issue with NAT traversal.

  11. #11
    Registered User
    Join Date
    Jan 2011
    Posts
    2

    Re: Nokia X3-02 with VOIP other than Gizmo5

    I installed some VoIp accounts on my C3-01 with n0kvoip, they are all not working. Now I have a lot of entries...how can I delete them? It's easy to install the .prov files via Bluetooth but how can they be removed?!

    Thank you for your help!

    sun
    Last edited by sun37; 2011-01-12 at 23:46.

  12. #12
    Registered User
    Join Date
    Mar 2003
    Posts
    4,105

    Re: Nokia X3-02 with VOIP other than Gizmo5

    Menu » Settings » Configuration » Def. config. sett. » long tap on the one » Delete »

  13. #13
    Registered User
    Join Date
    Jan 2011
    Posts
    2

    Re: Nokia X3-02 with VOIP other than Gizmo5

    Thank you traud, it works!

  14. #14
    Registered User
    Join Date
    Jun 2008
    Posts
    44

    Re: Nokia X3-02 with VOIP other than Gizmo5

    stambo98, see http://www.forum.nokia.com/info/sw.n..._Releases.html for the differencies. Perhaps the biggest one is the HD Voice support

    sun37, haven't had any problems with that tool. have you reported the problems for them ? atleast got an response when wanting to have one provider more supported.

  15. #15
    Registered User
    Join Date
    Apr 2011
    Posts
    1

    Re: Nokia X3-02 with VOIP other than Gizmo5

    hi stambo98,

    i have changed the voip provider, username and password in the .xml, i compiled .xml to .prov and push it to the nokia x3-02 and saved the config, it gets logged in the voip server, i can dial and hear the ringing but once the call gets connected, i cannot hear the other person and the other person cannot hear me.

    so please help me out.

Similar Threads

  1. Nokia 6300i with Voip - other than Gizmo5
    By Soegaard in forum VoIP
    Replies: 125
    Last Post: 2010-12-22, 08:29
  2. Replies: 1
    Last Post: 2010-11-08, 14:38
  3. Nokia x3-02 touch and type
    By chaitanyabhargav27 in forum General Development Questions
    Replies: 1
    Last Post: 2010-10-06, 08:09
  4. Issues with Mp3 progressive_download Playing on S40 V3FP5 with Nokia X3-02
    By vngwcc in forum Mobile Java Media (Graphics & Sounds)
    Replies: 0
    Last Post: 2010-10-05, 18:53
  5. Nokia X3-02, which SDK, and what about the soft keys?
    By levon.levonian in forum Mobile Java Tools & SDKs
    Replies: 2
    Last Post: 2010-08-24, 00:19

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×