×

Discussion Board

Results 1 to 8 of 8
  1. #1
    Registered User
    Join Date
    Dec 2010
    Posts
    7

    Problem with PyS60 Application Packager

    Hi,
    I have downloaded Python for S60 2.0.0 from here: http://developer.symbian.org/wiki/Fi....0.0_Setup.zip
    I have successfully installed the interpreter and script shell onto my N97 but when I try to open PyS60 Application Packager on my vista laptop to put my own applications on the phone it doesn't recognise the file and doesn't know how to open it even though it all installed successfully so I am unsure how I can place my own applications onto the phone to run in python.
    I've looked everywhere for a solution and have had no luck. Does anyone know how I might solve this issue? I really need to get my own applications onto the phone, I've got python installed on it fine.
    Thanks. (I'm a bit new to this so I apologise if any of this is wrong but I think I've properly explained my problem)

  2. #2
    Super Contributor
    Join Date
    Oct 2007
    Location
    Deva, Romania
    Posts
    3,471

    Re: Problem with PyS60 Application Packager

    Hi,

    The Application Packager is used to make sis files from Python scripts (py files). You then put the sis files in your phone, which is connected to your computer (you should have Nokia PC Suite installed).

  3. #3
    Registered User
    Join Date
    Dec 2010
    Posts
    7

    Re: Problem with PyS60 Application Packager

    Hi, yeah I've got pc suite installed, like I say I've got all the necessary files installed on the phone and the examples that come with it run fine. I've also got a load of py files I've written and tested in an emulator ready to go onto the phone. My problem is I can't work out how to run the Application packager, when I click on it in Start>All Programs>PythonForS60 2.0.0>Application Packager Vista asks me what program to use to run it rather than it just running like I think it should? I tried opening it in Notepad++ but obviously that just shows the source code.
    Any help is very very appreciated.

  4. #4
    Super Contributor
    Join Date
    Oct 2007
    Location
    Deva, Romania
    Posts
    3,471

    Re: Problem with PyS60 Application Packager

    That's strange... Do you have Python on your computer (the recommended version is 2.5.4)? If you do, have you tried reinstalling PyS60 (perhaps uninstall, reboot, install again)?

  5. #5
    Registered User
    Join Date
    Dec 2010
    Posts
    7

    Re: Problem with PyS60 Application Packager

    So even though I thought I had installed python on my computer I somehow hadn't. I have now installed it (Python 2.7) and told Application Packager to open using pythonw. Now when I run Application Packager nothing happens, the swirling blue 'wait' symbol shows up next to the mouse for about 2 seconds and then nothing.
    I've tried uninstalling and reinstalling everything and resetting the laptop and still nothing. Any idea what I might be doing wrong? Is it the version of python I've installed maybe?

  6. #6
    Super Contributor
    Join Date
    Oct 2007
    Location
    Deva, Romania
    Posts
    3,471

    Re: Problem with PyS60 Application Packager

    Quote Originally Posted by Leakster View Post
    Is it the version of python I've installed maybe?
    It's very probable. Like I said, the recommended version is 2.5.4. Make sure you uninstall 2.7, then install 2.5 and tell Windows to open the Application Packager with pythonw (or also reinstall PyS60).
    Last edited by bogdan.galiceanu; 2010-12-04 at 18:42.

  7. #7
    Registered User
    Join Date
    Dec 2010
    Posts
    7

    Re: Problem with PyS60 Application Packager

    I'll try that, cheers for the help.

  8. #8
    Registered User
    Join Date
    Dec 2010
    Posts
    7

    Re: Problem with PyS60 Application Packager

    Right, I uninstalled Python 2.7 and PythonForS60 and removed any trace from my computer. Then I installed Python 2.5.4 (http://www.python.org/download/releases/2.5.4/) and then reinstalled PythonForS602.0.0 (http://developer.symbian.org/wiki/Fi....0.0_Setup.zip) and now when I run Application Packager it asks how I want to open so I browse to pythonw and click open and nothing at all happens, as if I'd just clicked cancel. It doesn't register that I've told it to use pythonw at all and behaves like it is still waiting for me to use it. Every other program (IDLE, Scribble etc) seem to work absolutely fine without any direction of how to open them. It's just Application Packager that doesn't want to open. Any idea what I might be doing wrong now? I'm really at a loss.
    Thanks for all the help.

Similar Threads

  1. PyS60, Python 1.9.3 and the Application Packager
    By CGhostGroup in forum Symbian
    Replies: 12
    Last Post: 2011-06-08, 17:11
  2. Replies: 6
    Last Post: 2010-08-10, 21:34
  3. Can not create sis file with application packager
    By flying_hypo in forum Symbian
    Replies: 4
    Last Post: 2010-02-18, 07:02
  4. Application packager - additional options. Syntax?
    By hansihinterseher in forum Symbian
    Replies: 2
    Last Post: 2010-01-31, 18:56
  5. Where is pyS60 application packager for 1.9.3
    By kashif_iftikhar in forum Symbian
    Replies: 3
    Last Post: 2009-03-27, 04:41

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×