×

Discussion Board

Results 1 to 4 of 4
  1. #1
    Registered User
    Join Date
    Dec 2010
    Posts
    32

    Qt Creator giving error

    Hi All,

    I am new to this qt, Whenever I add QWebView to form (or create QWebVeiw instance through code) and run the application it gives following errors

    1. symbol(s) not found
    2.collect2: Id returned 1 exit status

    I am running it on MAC

    Thanks in advance

    Siddu

  2. #2
    Super Contributor
    Join Date
    Dec 2005
    Location
    England,UK
    Posts
    1,600

    Re: Qt Creator giving error

    Quote Originally Posted by siddugh View Post
    Hi All,

    I am new to this qt, Whenever I add QWebView to form (or create QWebVeiw instance through code) and run the application it gives following errors

    1. symbol(s) not found
    2.collect2: Id returned 1 exit status

    I am running it on MAC

    Thanks in advance

    Siddu
    Yes its a bit obscure you a missing a library call which probably does not exist
    make sure the library is linked in the .pro CONFIG line by declaring the library.
    When Qt creator builds go the to compilation window rather than the build window in the bottom pane and look at the log to see whats missing and more detail on the errors
    Jim

  3. #3
    Super Contributor
    Join Date
    Mar 2009
    Posts
    1,024

    Re: Qt Creator giving error

    Hi,
    That's a linker error. it complains about the "missing" or better the "not found" webkit library.
    Adding the following line to your Qt project file and generating a new Makefile running again qmake will solve this issue.

    QT += webkit

  4. #4
    Registered User
    Join Date
    Dec 2010
    Posts
    32

    Re: Qt Creator giving error

    Thanks Jim

    You are right, its working now

    I added QT += network \
    webkit

    in .pro file.

Similar Threads

  1. Qt Creator update deletes QT Creator
    By arttu76 in forum [Archived] Qt SDKs and Tools
    Replies: 13
    Last Post: 2011-06-08, 10:45
  2. Qt Creator giving error
    By amresh_kumar1986 in forum [Archived] Qt SDKs and Tools
    Replies: 8
    Last Post: 2011-02-07, 06:23
  3. General OS-related error when run on device from within QT creator
    By tomjanssens in forum [Archived] Qt SDKs and Tools
    Replies: 1
    Last Post: 2010-11-19, 09:26
  4. Replies: 7
    Last Post: 2010-07-14, 14:58

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×