×

Discussion Board

Results 1 to 3 of 3
  1. #1
    Registered User
    Join Date
    Aug 2009
    Posts
    39

    Exclamation samegame "Qt.labs.particles" is not installed

    大家好,我在运行NokiaQtSDK\Demos\4.6\declarative\samegame 这个例子时,出现了如下错误
    error loading block component
    file:///F:/NokiaQtSDK/Demos/4.6/declarative/samegame/SamegameCore/BoomBlock.qml:43 module "Qt.labs.particles" is not installed

    查了下好像说是路径没有包括进来还是怎么回事,但是不知道怎么解决,请大家帮帮忙,谢谢了!
    www.devdiv.net http://discussion.forum.nokia.com
    向坛子的牛人学习,缩小与梦想之间的步伐!

    超于自己! Figthing!
    我就是个搞Symbian的,咋的了?!

  2. #2
    Registered User
    Join Date
    Jun 2010
    Posts
    63

    Re: samegame "Qt.labs.particles" is not installed

    这是Nokia Qt SDK1.0.2中的一个bug,将下一版中修复,要运行这个例子,将BoomBlock.qml:43行注释掉,然后 particle 这个element不用了, 虽然没有了粒子爆炸效果,但是不影响运行了
    更多信息,示例参考
    http://wiki.forum.nokia.com/index.php/Qt_开发

  3. #3
    Super Contributor
    Join Date
    Mar 2003
    Location
    Beijing
    Posts
    3,609

    Re: samegame "Qt.labs.particles" is not installed

    Currenty Nokia Qt SDK 1.0.2 may not support QML well. Please use the Qt 4.7.1 at:

    http://qt.nokia.com/downloads

    If you want to make it run in a phone, you may need to install the "Qt libraries 4.7.1 for Symbian (265 MB)" package as well.

    By the way, the Nokia Qt SDK 1.1 beta will be coming soon. It will ease your development.
    Liuxg
    Forum Nokia <a href="http://wiki.forum.nokia.com/index.php/Qt_开发"><font color="red">Qt Application Development Resources</font></a>

Similar Threads

  1. Qt/3D with QML bindings - "module "Qt3D" is not installed"
    By John de Witt in forum [Archived] Qt SDKs and Tools
    Replies: 0
    Last Post: 2010-10-20, 04:53
  2. Replies: 3
    Last Post: 2010-06-30, 01:17
  3. Replies: 3
    Last Post: 2009-06-18, 21:42
  4. Replies: 0
    Last Post: 2005-09-14, 15:51

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •