×

Discussion Board

Results 1 to 4 of 4
  1. #1
    Super Contributor
    Join Date
    May 2006
    Location
    Beijing,China
    Posts
    1,190

    Chinese character can not be displayed in N97mini

    HI,

    I use this code in the application:
    QTextCodec::setCodecForTr(QTextCodec::codecForLocale());

    In N8, Chinese characters can be displayed correct.
    while on N97mini, Chinese characters can not be displayed(mess code)

    if I use: QTextCodec::setCodecForTr(QTextCodec::codecForName("GB18030-0"));
    both N97 mini and N8 are wrong.

    all the characters are wrapped in tr("汉字")

    why?
    [I][COLOR="Orange"]xhsoldier[/COLOR][/I]
    [email]xhsoldier@gmail.com[/email]/[email]xhsoldier@163.com[/email]

  2. #2
    Super Contributor
    Join Date
    Mar 2003
    Location
    Finland
    Posts
    9,553

    Re: Chinese character can not be displayed in N97mini

    Is the N97 mini one with a firmware version intended for the Chinese market (i.e., does it have Chinese language support - fonts - in the first place)?

    How about posting screenshots, too? I.e., a screenshot that shows how things are displayed on the N97 mini (and also another showing what the same code shows on the N8).

  3. #3
    Super Contributor
    Join Date
    May 2006
    Location
    Beijing,China
    Posts
    1,190

    Re: Chinese character can not be displayed in N97mini

    The n97 mini is for Chinese market.
    [I][COLOR="Orange"]xhsoldier[/COLOR][/I]
    [email]xhsoldier@gmail.com[/email]/[email]xhsoldier@163.com[/email]

  4. #4
    Super Contributor
    Join Date
    May 2006
    Location
    Beijing,China
    Posts
    1,190

    Re: Chinese character can not be displayed in N97mini

    I changed to QTextCodec::setCodecForTr(QTextCodec::codecForName("GB2312"));

    this works.

    it seams that GB18030-1 is not supported, though the doccument said it support.
    [I][COLOR="Orange"]xhsoldier[/COLOR][/I]
    [email]xhsoldier@gmail.com[/email]/[email]xhsoldier@163.com[/email]

Similar Threads

  1. Replies: 0
    Last Post: 2007-03-08, 14:13
  2. Replies: 2
    Last Post: 2006-11-07, 07:07
  3. Special Character Table dialog not displayed ........
    By chishti.hameed in forum Symbian User Interface
    Replies: 1
    Last Post: 2005-07-16, 08:57
  4. UTF-8: Chinese characters not displayed correctly?
    By so_real in forum Browsing and Mark-ups
    Replies: 1
    Last Post: 2004-07-29, 15:38
  5. Chinese characters are not displayed
    By Nokia_Archive in forum Browsing and Mark-ups
    Replies: 1
    Last Post: 2002-05-14, 20:35

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×