×

Discussion Board

Results 1 to 10 of 10
  1. #1
    Registered User
    Join Date
    Nov 2010
    Posts
    43

    N8 and Qt Mobility 1.1

    I have few questions regarding N8 and Qt Mobility... Which version of Qt Mobility is installed to N8? Or is there any? Does Qt Mobility 1.0.2 support Map and Location APIs?

  2. #2
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,167

    Re: N8 and Qt Mobility 1.1

    AFAIK, The maps related APIs are supported from 1.1.0 mobility, and thus it is not pre-installed into teh N8.

  3. #3
    Registered User
    Join Date
    Dec 2010
    Posts
    7

    Re: N8 and Qt Mobility 1.1

    Hi, I have a problem. I installed the 1.1.0 in my windows, and now I want to install it in a Nokia device. The Installation Guide says "Building Qt Mobility for Symbian is not necessary as the package contains pre-built binaries for the SDK and SIS file for the device. See the symbian\install.txt file on how to deploy these." But I can't find the "install.txt". What can I do? thanks

  4. #4
    Super Contributor
    Join Date
    Mar 2008
    Posts
    1,481

    Re: N8 and Qt Mobility 1.1

    Hi,
    Try these steps
    0. Download and Install QtSDK aftter these follow these steps (If you don't have exactly these version select What you have in the package)
    1. Connect your phone with PC via USB
    2. Install TRK (Start | Programs | SDK |Symbian^3 or Symbian^1 ) to your N8
    3. Install Qt 4.7.1 and Qt Mobility 1.1.0 (Install also other for example Qml...) to N8.

    Now you should be able to run any examples those comes with SDK. If problem please ask here again, somebody will answer it.

  5. #5
    Registered User
    Join Date
    Jan 2011
    Posts
    2

    Re: N8 and Qt Mobility 1.1

    Hi sorry to bump this older thread, but i'm following the exact process listed here except when i install qt 4.7.1 to my N8 i get errors when installing the Dependencies
    "pips installer is not upgradeable (-10256)" it asks if i wish to continue anyway and unfortunately when doing so i get the next error "Qt is not upgradeable (-10256)" and "QtWebKit is not upgradeable (-10256)" after continuing with the installation anyhow and moving on to install QT Mobility I'm told "qt 4.07 minimum is needed"

    also when attempting to install the webkit.sis etc included in the folder i get the error of "qt 4.07(1) required"

    im brand new at this so its quite confusing and frustrating :/

    hopefully you guys can help
    Last edited by stylinred; 2011-01-28 at 05:31.

  6. #6
    Super Contributor
    Join Date
    Oct 2008
    Location
    INDIA
    Posts
    2,326

    Re: N8 and Qt Mobility 1.1

    Quote Originally Posted by stylinred View Post
    Hi sorry to bump this older thread, but i'm following the exact process listed here except when i install qt 4.7.1 to my N8 i get errors when installing the Dependencies
    "pips installer is not upgradeable (-10256)" it asks if i wish to continue anyway and unfortunately when doing so i get the next error "Qt is not upgradeable (-10256)" and "QtWebKit is not upgradeable (-10256)" after continuing with the installation anyhow and moving on to install QT Mobility I'm told "qt 4.07 minimum is needed"

    also when attempting to install the webkit.sis etc included in the folder i get the error of "qt 4.07(1) required"

    im brand new at this so its quite confusing and frustrating :/

    hopefully you guys can help
    From where you get the source ?
    Here is the link where you get the Qt related installer package : smart installer for the Symbian

    If you are getting the same errors the report your errors in the comment page of that article.

    Best regards,

  7. #7
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,167

    Re: N8 and Qt Mobility 1.1

    Note that if you have the latest Qt SDK, you should skip the last step "3. Install Qt 4.7.1 and Qt Mobility 1.1.0 (Install also other for example Qml...) to N8", since those are already included in the latest sis files included in the SDK.

  8. #8
    Super Contributor
    Join Date
    Mar 2008
    Posts
    1,481

    Re: N8 and Qt Mobility 1.1

    Hi,
    I guess,
    your N8 has Qt 4.7.1 and probably Qt mobility 1.1.0

  9. #9
    Registered User
    Join Date
    Jan 2011
    Posts
    2

    Re: N8 and Qt Mobility 1.1

    hey thanks for the replies guys it looks like after attempting those installs it messed up my Ovi Store (it wont load now) as for my source i downloaded the files from the QT nokia downloads page.

    i dont think my N8 has qt mobility 1.1 already installed as the DJ Turntable doesn't load


    i dont have the time right at the moment but i thought id give this little update

    anyhow thanks for the help

  10. #10
    Super Contributor
    Join Date
    Mar 2008
    Posts
    1,481

    Re: N8 and Qt Mobility 1.1

    You can always use this to check the version of Qt and mobility in devices
    qDebug() << "QT_VERSION_STR: " << QT_VERSION_STR;
    qDebug() << "QTM_VERSION_STR: " << QTM_VERSION_STR;

Similar Threads

  1. Qt Creator code completion not working with Qt Mobility for Symbian
    By ceefour in forum [Archived] Qt Mobility Project
    Replies: 4
    Last Post: 2011-09-10, 05:02
  2. Qt Mobility API not working with Nokia Qt SDK + incomplete docs
    By remy_david in forum [Archived] Qt Mobility Project
    Replies: 15
    Last Post: 2011-06-10, 14:38
  3. Qt Mobility missing at N8
    By mando7stam in forum [Archived] Qt Mobility Project
    Replies: 7
    Last Post: 2010-09-28, 12:22
  4. Replies: 3
    Last Post: 2010-06-30, 01:17

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×