×

Discussion Board

Results 1 to 1 of 1
  1. #1
    Registered User
    Join Date
    Nov 2010
    Posts
    16

    Building QT 4.6.3 for S60 Simulator

    Hi

    I'm trying to build QT 4.6.3 for S60 Simulator - one that comes with Symbian^3 SDK..

    The instructions I'm using are here:
    http://doc.qt.nokia.com/4.7-snapshot...l-symbian.html

    I've added c:\qt\4.6.3\bin to my path...

    devices confirms I'm using the correct S60 SDK.

    However, on the first step, which says to run the following command in c:\qt\4.6.3, I'm getting the following error:
    Support for S60.............yes
    Symbian DEF files enabled...yes
    Running syncqt...
    Creating qmake...
    execute: File or path is not found (mingw32-make)
    execute: File or path is not found (mingw32-make)
    Cleaning qmake failed, return code -1


    I don't have mingw_make.exe, only "mingw32-make.exe" in C:\Nokia\devices\Nokia_Symbian3_SDK_v0.9\epoc32\tools\rom\imaker

    If make a copy of mingw32-make.exe from wingw*.exe and try configure, I'm getting:
    "Sorry, \epoc32\gcc\bin\g++.exe is not supported in this release. Please use a di
    fferent
    device. Use 'devices' to view the available devices.
    mingw32-make: *** [project.o] Error 2
    Building qmake failed, return code 2"


    Any ideas of what the *correct* instructions are?

    Or... Can I download prebuilt QT 4.6.3 .sis files for the S60 Simulator anywhere?

    Thanks

    Stewart
    Last edited by stewarth01; 2010-12-17 at 02:20.

Similar Threads

  1. Replies: 3
    Last Post: 2010-06-30, 01:17
  2. Error while building project for Qt Simulator
    By stegemann in forum [Archived] Qt SDKs and Tools
    Replies: 1
    Last Post: 2010-06-26, 11:41

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×