×

Discussion Board

Results 1 to 3 of 3
  1. #1
    Registered User
    Join Date
    Nov 2010
    Posts
    15

    Device compilation error [Could not load shared library symbols ]

    I'm new in Qt and I'm developing an application for Symbian^3, and in the simulator works great, but when i compile in the device, throws me the following error:

    Could not load shared library symbols for 30 libraries, e.g. C:\sys\bin\QtCore.dll.Do you need "set solib-search-path" or "set solib-absolute-prefix"?"

    What this error means?

    I'm using QT creator 2.0.1
    Windows 7 x32

  2. #2
    Super Contributor
    Join Date
    Nov 2009
    Location
    Minnesota, USA
    Posts
    3,209

    Re: Device compilation error [Could not load shared library symbols ]

    Do you have "QT += core" in your .pro file?

  3. #3
    Registered User
    Join Date
    Nov 2010
    Posts
    15

    Re: Device compilation error [Could not load shared library symbols ]

    yes, this is the qt modules

    QT += core gui network sql

    symbian {
    TARGET.UID3 = 0xea2fb24d
    TARGET.CAPABILITY += networkservices
    TARGET.EPOCSTACKSIZE = 0x14000
    TARGET.EPOCHEAPSIZE = 0x020000 0x8000000
    }

Similar Threads

  1. Help ! "Failed to load the JNI shared library"
    By kalpspugaz in forum Mobile Java Tools & SDKs
    Replies: 3
    Last Post: 2013-04-06, 02:39
  2. [Moved] Can't load debugging symbols (on-device)
    By Theril in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 2
    Last Post: 2008-07-02, 11:55
  3. Dll library load error -46
    By komicek in forum Symbian
    Replies: 2
    Last Post: 2008-06-21, 09:16

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×