×

Discussion Board

Results 1 to 3 of 3
  1. #1
    Registered User
    Join Date
    Jan 2009
    Location
    ભારત->ગુજરાત->ભાવનગર
    Posts
    279

    Attachments problem

    Code is given below:
    Code:
     bool error=image.save("/home/user/MyDocs/.images/viral.png");
         qDebug()<<error;
    
         QMessage msg;
         msg.setType(QMessage::Email);
    
         // Set recipient for our email message
    
    
    
         // Define message subject, body and append attachment
         msg.setSubject("How are you ");
         msg.setBody("Hiiiiiiiiiii");
    
    //     QStringList attachments;
    //     attachments<<"";
    
         msg.appendAttachments(QStringList("/home/user/MyDocs/.images/viral.png"));
         QMessageService service;
         service.compose(msg);
    1) I am saving image ..its working
    2) I have to attach that image ,for that code is written,email is also opening in my phone default mailbox but with no attachments??????

    What to do ??
    Regards
    Viral Parmar

  2. #2
    Registered User
    Join Date
    Dec 2010
    Posts
    4

    Re: Attachments problem

    I have not done much with Qt Mobility, yet. Doesn't the compose() open a composer window? have you tried the send() method instead?

  3. #3
    Registered User
    Join Date
    Jan 2009
    Location
    ભારત->ગુજરાત->ભાવનગર
    Posts
    279

    Re: Attachments problem

    Doesn't the compose() open a composer window?
    ya default window is opened but without any attachment...as shown i my code below:
    Code:
     msg.appendAttachments(QStringList("/home/user/MyDocs/.images/viral.png"));

    have you tried the send() method instead?
    i dont need to used send() function as i have already a send button in my default email client...
    Regards
    Viral Parmar

Similar Threads

  1. AttachmentManager is NULL? - problem accessing BlueTooth message attachments
    By rarora05 in forum Symbian Networking & Messaging (Closed)
    Replies: 5
    Last Post: 2010-09-03, 21:50
  2. IMAP4 Attachments
    By scoe in forum Symbian Networking & Messaging (Closed)
    Replies: 0
    Last Post: 2007-02-15, 22:13
  3. Problem with MIME in attachments
    By birAdam in forum General Messaging
    Replies: 1
    Last Post: 2006-10-17, 07:39
  4. Message attachments
    By vodkaloon in forum Symbian
    Replies: 0
    Last Post: 2004-11-01, 09:02
  5. Email attachments
    By dd_plus in forum Mobile Java Networking & Messaging & Security
    Replies: 1
    Last Post: 2004-03-22, 13:31

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •