×

Discussion Board

Results 1 to 3 of 3
  1. #1
    Registered User
    Join Date
    Dec 2010
    Posts
    2

    help! help! QSound doesn't work in my Phone

    my code is just like this
    Code:
    QSound::play("hit.wav");
    but it does work in the simulator, but it does not work in my phone(phone type: E72);
    why?

    At first i think , maybe the file "hit.wav" copy failed into my phone;
    but when i use QFile::exists("hit.wav"). That told me the file is existed in my phone! so i am confused?

    Code:
    QFile file("hit.wav");
    QFileInfo fileinfo(file);
    fileinfo.absoluteFilePath();
    fileinfo.absoluteFilePath() told me that the file path is " c:\private\ed3632c3\hit.wav " ,And that seems to be right too; But there are no any sound

    who can tell me why??

  2. #2
    Registered User
    Join Date
    Dec 2008
    Posts
    12

    Re: help! help! QSound doesn't work in my Phone

    check the availabilty of audio facilities of the platform with isAvailable() static function before playing .. may be E72 support for wav files is one more thing to check ..

  3. #3
    Registered User
    Join Date
    Dec 2010
    Posts
    2

    Re: help! help! QSound doesn't work in my Phone

    Quote Originally Posted by pushyamikiran View Post
    check the availabilty of audio facilities of the platform with isAvailable() static function before playing .. may be E72 support for wav files is one more thing to check ..
    Thank for your hlep, I have checked the availabilty of audio facilities 。isAvailable() returns true 。but there are no any sound too.

Similar Threads

  1. QSound Usage
    By atonical in forum Nokia N9
    Replies: 3
    Last Post: 2010-04-12, 07:17

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×