×

Discussion Board

Results 1 to 5 of 5
  1. #1
    Regular Contributor
    Join Date
    Oct 2010
    Location
    chennai
    Posts
    97

    Exclamation problem with moc_files while running application

    Hi..
    I need to change the qcalendarwidget look and feel and insert some additional data to each cell of it.. so i cloned the qcalendarwidget native code and have done some modifications.. all is working fine.. but problem is when ever i run for first time its saying static meta object is refined in moc_qcalendarwidget.cpp. .. then every time i comment that and run again.. it works fine.. but shows some warnings like "overriding function scope is application dll .."
    My question is why its showing error for first time run.. and why these wornings are comming
    Thanks & Best Regards
    Srinivas

  2. #2
    Super Contributor
    Join Date
    Mar 2004
    Location
    Singapore
    Posts
    9,968

    Re: problem with moc_files while running application

    Are you using the same name for the classes ? then yes there might be conflight in signal slot linking and give rise to a error once only.

  3. #3
    Regular Contributor
    Join Date
    Oct 2010
    Location
    chennai
    Posts
    97

    Re: problem with moc_files while running application

    actually im importing native qcalendarwidget and made some changes to it.. directly.. so that my changes reflect original qcalendarwidget.cpp file.. If I just clone it and change the classname then the changes are not reflectcting at all.. so directly i changed the qcalendarwidget.cpp file
    Thanks & Best Regards
    Srinivas

  4. #4
    Super Contributor
    Join Date
    Nov 2009
    Location
    Minnesota, USA
    Posts
    3,209

    Re: problem with moc_files while running application

    Don't do that.

  5. #5
    Regular Contributor
    Join Date
    Oct 2010
    Location
    chennai
    Posts
    97

    Re: problem with moc_files while running application

    I tried many ways to customize the font and background ..using qabstract item model but there is no effect on the output..so i tried to modify the native calendar.. if there is any advice on how to change background color and font size and font alignment please let me know.. and one more thing.. I need to align the dates 7px from top of cell in 240by 320 view i tried lot of ways but no use.. if u have any solutions please let me know
    Thanks & Best Regards
    Srinivas

Similar Threads

  1. Problem While Running Standalone application created
    By rishabhgupta in forum Symbian
    Replies: 4
    Last Post: 2008-06-18, 16:30
  2. A problem while running application on mobile
    By pom_cc in forum Mobile Java General
    Replies: 3
    Last Post: 2007-08-08, 18:25
  3. Application Error While running application in real device
    By praveen_bluebird in forum Mobile Java General
    Replies: 4
    Last Post: 2006-11-21, 04:39
  4. Replies: 0
    Last Post: 2005-11-27, 20:27
  5. Replies: 0
    Last Post: 2004-10-26, 15:02

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×