×

Discussion Board

Results 1 to 4 of 4
  1. #1
    Registered User
    Join Date
    Dec 2010
    Posts
    4

    Cannot compile the "Get continuous location updates using Qt Mobility API"

    Hey i am trying to use the QT mobility API and wanted to try out how the example http://wiki.forum.nokia.com/index.ph...t_Mobility_API works, but i am having troubles to compile it although it is marked as tested.
    The errors i receive are the following:
    - undefined reference to `QtMobility::QGeoPositionInfoSource::createDefaultSource(QObject*)' LocationWatcher.cpp line 19 /LocationWatcher C/C++
    - undefined reference to `QtMobility:perator<<(QDebug, QtMobility::QGeoPositionInfo const&)' LocationWatcher.cpp line 47 /LocationWatcher C/C++ Problem
    - undefined reference to `QtMobility::QGeoPositionInfo::isValid() const' LocationWatcher.cpp line 46 /LocationWatcher C/C++ Problem

    can someone help me with these- i am using S60_5th_Edition_SDK_v1.0 with QT 4.6.3 installed , for the mobilty API installation i followed the instructions in the paccage.
    Last edited by ivo84stz; 2011-01-03 at 11:06.

  2. #2
    Regular Contributor
    Join Date
    Oct 2008
    Location
    Oslo, Norway
    Posts
    329

    Re: Cannot compile the "Get continuous location updates using Qt Mobility API"

    Hi,

    As it says in the article, you'll have to add

    Code:
    CONFIG += mobility
    MOBILITY += location
    into your .pro file. Also make sure that qmake is run after modifying it (try doing a rebuild or a clean build).

  3. #3
    Registered User
    Join Date
    Dec 2010
    Posts
    4

    Re: Cannot compile the "Get continuous location updates using Qt Mobility API"

    TEMPLATE = app
    TARGET = LocationWatcher
    CONFIG += mobility
    MOBILITY += location
    QT += core \
    gui
    HEADERS += LocationWatcher.h
    SOURCES += LocationWatcher_reg.rss \
    main.cpp \
    LocationWatcher.cpp
    FORMS +=
    RESOURCES +=

    symbian:TARGET.UID3 = 0xED5C8CFC

    that was my .pro file from the beginning tryied cleaning and rebuilidng but the errors are the same

  4. #4
    Registered User
    Join Date
    Dec 2010
    Posts
    4

    Re: Cannot compile the "Get continuous location updates using Qt Mobility API"

    is anyone familiar with this problem ??
    Last edited by ivo84stz; 2011-01-01 at 15:58.

Similar Threads

  1. Failed because of "Outdated version of Qt Mobility"
    By revorgm in forum [Closed] Publishing to Nokia Store
    Replies: 2
    Last Post: 2010-11-24, 15:29
  2. Replies: 9
    Last Post: 2010-10-25, 09:21
  3. Replies: 3
    Last Post: 2010-06-30, 01:17
  4. jsr-179 Location API, "Authorisation Failed" on .jar install
    By ibzter in forum Mobile Java Networking & Messaging & Security
    Replies: 3
    Last Post: 2007-06-14, 23:54

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×